Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 70-200 f2.8 USM lens focus problem


Hi everyone.

Have just joined the forum :-). I had a great idea of trying to photograph the flypast during King Charles III coronoation over the weekend. I was hoping to use my original (Mk 1 lens dating back to the 1990's) 70-200 f2.8 lens and my 1.4x extender only to find the lens will not autofocus any more with my trusty EOS-40D camera. The lens in in mint condition, is stored (vertically) in its original Canon black "leather" case, and has only been used a handful of times (I'd say less than 500 photos will have been taken with it!). This problem occurs with or without the extender and all my other lenses work OK on my 40D. Manual focus is fine as is the zoom. I've never had the lens serviced and that may well be what is needed but what could have broken for it to stop working? Any suggestions on any (cheap) fixes would be appreciated.

Thanks in advance....Ian




The only cheap and simple user fixes are first cycle the AF/MF switch on the lens rapidly several times ending in the AF position. 

If this doesn't work, I guess cleaning the contacts on the lens side of the mount could be tried although it isn't likely the issue since the contacts get wiped every time a lens is mounted/dismounted.  But it won't hurt anything if you are careful.  Use a soft cloth moistened with the highest percentage isopropyl alcohol you can find and wipe them gently before mounting the lens again.

Canon probably doesn't service a lens this old anymore so you will need to find a third party camera shop in your area that does such work.  Parts availability might also be an issue for this version so proceed carefully if there is a high minimum cost for diagnosis.


EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video

Rdoger, thanks for the response. Have tried the switch trick to no avail. Will investigate repair costs before considering options. Canon's support site does mention the 7-year limit to the age of items sent in for repair. Clearly if costs are too high I may have to use the lens as manual-focus only 🙂


When you have used the 70-200 lens previously, have you been using it with the 1.4 extender? 

Also, what version is the extender?

cheers, TREVOR

Before you ask us, have you looked in the manual or on the Canon Support Site?
"All the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

Hi, thanks for the response. I last used the lens well before Covid. Maybe 5-7 years ago. It's been in it's case, standing vertically, the whole time. The extender is the original 1.4x Canon extender dating back to when I bought the lens in the 90's. The problem occurs with or without the extender attached. Coupled with that since other lenses work OK on my 40d I expect the problem to be with the 70-200 Lens itself 😞



Actually there should be no problem getting that lens serviced, in spite of its age. The EF 70-200mm f/2.8 USM (non-IS) has been in production until just recently... the last year or so... and is still available to purchase new in many stores.

The "7 year age limit" applies to when a product was discontinued... not when it was first introduced. The "7 years" is just an estimate anyway... for example parts ran out to repair the EF 200mm f/1.8L in just 2 or 3 years after that lens was discontinued, essentially turning any that needed a new focus motor into an expensive paper weight (altho AFAIK they can still be focused manually).

A lens that's just been sitting in storage shouldn't fail. I suspect it's some oxidization in a switch or similar that's preventing it from working. Try the previously recommended method of switching AF on and off a number of times. Those switches are self-cleaning, but only when they're operated regularly. You might also operate any other switches a few times, such as the focus limiter.

Carefully inspect the electronic contacts on the base of the lens too, as well as the corresponding pins inside the front of your camera. Those are gold plated to prevent oxidization, so don't use anything abrasive on them... but try the isopropyl alcohol cleaning again. Check that none of the pins inside the front of the camera appear to be "stuck"... they are spring loaded and can be tested gently with a fingernail or wood/plastic toothpick or similar. Be careful around the camera's mirror and the lens' optics. 

You could send the lens to Canon for repair... but might check locally for a camera repair person first. It's probably something simple, if it's not just a cleaning that's needed.


Alan Myers
San Jose, Calif., USA
"Walk softly and carry a big lens."
GEAR: 5DII, 7DII (x2), 7D(x2), EOS M5, some other cameras, various lenses & accessories