cancel
Showing results for 
Search instead for 
Did you mean: 

mg2522

claris
Apprentice

i just purchased an mg 2522 and i have a chromebook and i cannot set up with just the usb wire is asking me for ppd...can someone help???

1 REPLY 1

ArthurJ
Product Expert
Product Expert

Hi claris,

The MG2522 was designed to work with Windows and Mac computers. There are not printer drivers for the Chrome operating system like there is for Windows and Mac OS and that is why the MG2522 is not compatible with your Chromebook. 

Some of our wireless models can work with the Chrome operating system's built in print system. The wireless model that would be close to your printer would be the TS3100 series printers. Since your current printer is not compatible with your Chromebook, you would qualify for the Canon Upgrade program. This is for out of warranty units which have been diagnosed to require service or are incompatible with a new or upgraded system. This program allows you the opportunity to purchase a replacement product discounted from the list price. Free ground shipping is included with your purchase. 

If you would like to take advantage of this offer, please call our Sales Department at (866) 443-8002 Mon-Sat, 9 AM to 9pm EST excluding holidays.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Announcements