cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Turn Enable bi-directional support on in the printer's Properties dialog box.

weberdj
Apprentice

I recently installed Windows 8.1.  ever since, I get the following error message

 

Cannot communicate with the printer.
Turn Enable bi-directional support on in the printer's Properties dialog box.

 

I've looked for the bi--directional support on the printer's dialog box, but to no avail.  Can someone help me?

 

 

21 REPLIES 21

Danny
Moderator
Moderator

Hi,weberdj!

So that the Community can help you better, we will need to know exactly which printer model you're using. That, and any other details you'd like to give will help the Community better understand your issue!

Thanks and have a great day!

Thank you. My printer is a MX882 Canon multifunctional. It was fine, and after I upgraded to 8.1, I have to change the default from MX882 Inkjet printer to MX 882. Then it will print, but I get the error message in the subject line.

I'm glad to see that I'm not the only one! I updated to 8.1 the other day then started getting the "Enable Bi-Directional Support" message the next day. Oddly, it still prints (I also have an MX882). Eagerly awaiting the response from support. Smiley Happy

 

Typically, I get a message that my printer is offline, but I think that has more to do with my laptop/wireless to wireless/printer connection than anything else. Usually I can just reconnect my laptop to my wireless--sometimes restart it totally-then it's fine.

Hello LindaSue,

 

Try the steps listed in the post above. If the issue still occurs, uninstall / reinstall the updated drivers from HERE.

 

If the issue still persists, please contact our support group: http://bit.ly/ContactCanon

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I'm using a pixma ip3300.  Also the reset button is flashing orange.

Ebony
Rising Star

Hello weberdj,

 

Try the following steps listed HERE to Enable Bi-directional support and let us know what happens.


If you need more immediate assistance, please contact our support group: http://bit.ly/ContactCanon

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thank you; this process resolved the issue. I had already reinstalled the driver, but still had the problem. Now, thanks to your info, the printer now works. But I still get the stupid error message. Another reason to hate Windows H8! Oh, well.

In following the steps outlined for Windows 8.1 access to Printer Properties, I do not get the window shown and there is no "Ports" window. Therefor, I do not see the box to check for Bi-directional printing. Please help. I have a Pixma MX700, have updated the setup and drivers. I can still copy but not scan.

Hi jcdhhi,

 

Are you using your PIXMA MX700 with a USB cable or are you using it wirelessly?

 

Are you using the 32 bit or 64 bit version of Windows 8?  To determine which version of Windows 8 you are using, please follow these steps:

 1.  Place the cursor in the upper right hand corner of your screen to display the Charms Menu.

 2.  Click on Search.

 3.  Type WINVER

 4.  On the right hand side, click Apps.

 5.  In the results, click winver.exe.

The version will be listed.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Avatar
click here to view the press release
Announcements