cancel
Showing results for 
Search instead for 
Did you mean: 

TR8520 error code 1660

MWhite9987
New Contributor

I am receiving error code 1660 for the small black tank. It was fine until I replaced the red tank next to it. Since then it will not recognize the Canon ink cartridge. I have tried using a new ink cartridge and that isn't working either. I have tried resetting the power. I have tried holding the stop button for 7 seconds. I have tried gently wiping down the chip. Nothing is working. I am afraid that my printer that I have only lightly used until today, though owned for 2 yrs, is broken. This is the second Canon Pixma printer I have had that just stopped working properly after only light use of about 2 years. I am not sure I will purchase another Canon printer if I cannot resolve this. The cartridges and printers are expensive and they aren't lasting like I was told they would which was the rationale for the price. I have tried customer support and none of the registrations I have been through are sticking and I have to create new registrations each time. I am beyond frustrated with Canon at this point. I have been a loyal Canon customer for 20 years and I am at my limit. A printer should survive through more than two cartridge set replacements.

 

Help me regain my faith and subsequent loyalty to Canon. I don't want to have to spend another couple hundred dollars on a printer plus the cartridges. It's cheaper and less of a headache to pay per page at the local Xerox or Library than all of this.

2 REPLIES 2

Texas760
New Contributor
I also was getting the 1660 error code. I used the "Chat" feature on the Canon website. Turns out that I ordered the wrong ink cartridges. The PIXMA TS9520 uses PGI-280 and CLI-281 tanks. I was using CLI-251 and PGI-250 ink tanks. Hope this helps...

I haven't received any response in the Chat, or the emails I have sent, nor have I been able to get through on the customer service line. Additionally, I am not using the wrong cartridges. The cartridge was working, then I replaced the one next to it then it never worked again and I haven't been able to get an answer or use my printer at all ever since.