Showing results for 
Show  only  | Search instead for 
Did you mean: 

System hangs when using Toolbox to scan mf4350d: Windows 8.1


I have been having trouble with my Canon mf4350d. It used to work with no problems prior to upgrade to Windows 8 then 8.1. Printing and faxing work fine, but when I try to scan, the Toolbox program hangs, dims out on the screen and says Not Responding. It's as if the Toolbox program does not work in Windows 8.x. When I remove and reload the drivers and Toolbox software, it works again for the first time but then will not work the second time. Any ideas on how I can fix this? I need a scanner that works all the time.


RE: Captret post on 06-04-2014 10:58 AM


A brilliant solution originated by Captret and IT WORKS FOR WINDOW 10!




(For window 8.1) Start> in the run box type. Services.msc

(For Window 10)  Press Window icon & R at the same time (window icon + R keyboard), in run box type  Services.msc

Scroll down to Windows Image Acquisition (WIA)

Right click, select Properties

Check that Startup type is set to Automatic

Click Log On Tab

Check that Local System account , and Allow service to interact with desktop is checked. Hit apply.

Click Recovery...Click on window next to First Failure, Scroll to Restart the Service. Hit apply.





I tried many solutions but none of them work EXCEPT this one.


At first I thought it is very complicated to setup as instructed. Indeed if follow Captret instructions step by step, it takes less than 5 minutes to complete and MF Toolbox will be ready to use.


Thanks a million!! Captret, you are a genius! Also your instruction is simple and easy to read.  x1000 Like!!!



p.s.  If you want to give kudo, please give it to Captret (posted on 06-04-2014 10:58 AM)



Wow, long lasting thread and Captret's solution still works! I have been using this same printer/scanner since my computer was windows 7 with pretty much no problems. Have been using with windows 10 now for some time as well and just last week started having this issue described here. Have no idea what got it started. followed thread until found this solution and worked like a charm. Weird thing is when went to Windows IMage acquisition log on tab the box next to This account was checked and a password was in the box but have no idea what it was and  have no idea what account that might have been there? Anyway, your fix worked for me. Thanks so much!