Showing results for 
Show  only  | Search instead for 
Did you mean: 

System hangs when using Toolbox to scan mf4350d: Windows 8.1


I have been having trouble with my Canon mf4350d. It used to work with no problems prior to upgrade to Windows 8 then 8.1. Printing and faxing work fine, but when I try to scan, the Toolbox program hangs, dims out on the screen and says Not Responding. It's as if the Toolbox program does not work in Windows 8.x. When I remove and reload the drivers and Toolbox software, it works again for the first time but then will not work the second time. Any ideas on how I can fix this? I need a scanner that works all the time.


I understand that this issue is frustrating; however, there are other factors that could cause issues with scanning, such as Windows updates, antivirus updates, or conflicts with other USB or imaging devices.


To isolate the issue, I recommend contacting our telephone technical support group. While I understand the forum may be the preferred method of communication, the real time feedback of a live technical support call would be very beneficial in this case.  Please contact us at 1-800-OK-CANON (1-800-652-2666).

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Tried all steps above, Toolbox would work once, then hang.
After spending an hour with CS with NO LUCK ....this worked for me,
Navigate to Windows folder > Twain_32 .
In this folder you'll find this file , wiatwain.ds and this folder MF4320
Copy the wiatwain.ds file to the MF4320 folder.
Copy all the files in the MF4320 folder to the Twain_32 folder.
Restart windows. This is working so far. Not sure moving which files made a difference.
Good luck!

My apologies to everyone who wasted time with my so-called fix, after unplugging printer , Toolbox hangs.
Hopefully someone at Canon or MS will come up with a fix.

Start> in the run box type. Services.msc

Scroll down to Windows Image Acquisition (WIA)

Right click, select Properties

Check that Startup type is set to Automatic

Click Log On Tab

Check that Local System account , and Allow service to interact with desktop is checked. Hit apply.

Click Recovery...Click on window next to First Failure, Scroll to Restart the Service. Hit apply.

Unlike my first attempt, this seems to work.

Please leave me some feedback before I try it on my other PC's.

All I can say is...... WHY THE HELL DID CANON NOT SUGGEST THIS! It worked like a charm! THANKS!!!


To all who may experience this painful situation, THIS WORKS! TRY IT.  "Mikey Likes it", to coin an old cereal commercial!


Thanks again.

You're Welcome!


Thanks for the feedback...I'll use this work-around on my other PC's. the scanner button on Paint doesn't work, but I don't use it anyway : )



Thanks for putting your solution out here for others. *fingers crossed* that it keeps working.

You're welcome.. hope they come out with an update soon.

Now it is having a problem with the feeder. It acknowledges that "an original is in the feeder" but then when I do my normal scan (pdf/auto mode) it pulls from the glass. If I change to (pdf/feeder) to force it to look at the feeder, I get an error that says "could not scan because the originals are not placed in the feeder or an error occured".


It's not consistant. Sometimes it works other times it doesn't. Sometimes if I turn everything off and pull usb cord and restart everything and blow a wish on a dandelion and rub my belly while patting my head it works. other times all my lucky tricks do nothing and I have to manually scan the papers in on the glass.


any body else having this happen or at least have some lucky tricks I can use.


Have canon imageclass mf4570dn recently updated to a new computer using windows 8.1. did Captret's for the "system hanging" which worked great. This started happening shortly after that but since it's intermitent I dealt with it but now it's drivinig me crazy.


*fingers crossed* that someone can help.

@Captret wrote:
Please leave me some feedback before I try it on my other PC's.


Seems to have worked for my MF4150. Thanks!