Showing results for 
Show  only  | Search instead for 
Did you mean: 

Scanner not available while in use - error


I have been scanning over a home network to my iMac without problem from my MX922 without problem for some time.  Now I  get an error message 2.249.0, the scanner is not available while in use by another application or user...


Restarting things does not seem to help, nor does re-selectin the IMac as the scan destination.Running OSX 10.9.5.


How can this be fixed?






Hi ktbills,


We can reset the printer system on the computer to try and resolve the issue. To do this, please follow these steps:


1. Go to your Apple icon on the upper left corner of your screen.


2. Click System Preferences.


3. Click Print & Fax


4. Right click your printer on the left and select "Reset printer system". Note: If right click does not work, press and hold the

control key on your keyboard and then click the mouse button.


5. If your printer is still listed on the left select your printer and then click the minus (-) button to delete it.


6. Restart your Mac.


Next, we will want to download the latest drivers from the Canon USA website. Please click here to go to to the PIXMA MX922 Drivers and Software page.  Once on the initial download page for your model, please do the following:


1. Verify that the operating system detected in the "OPERATING SYSTEM" drop-down menu is correct, and if it is not, please click the drop-down menu to select your operating system.


2. Next, please click on the red arrow next to the "RECOMMENDED FOR YOU" section and click on the CUPS driver file. When you do, a red DOWNLOAD button will appear. Please click on the checkbox below the DOWNLOAD button, then click the red DOWNLOAD button to begin the download. The time for the download process may vary depending on the speed of your Internet connection and the size of the file being downloaded.


Once you have downloaded and installed the CUPS driver file from the website, please also install all other items from the Recommended for You and Drivers section of the website. To install the software that comes with the printer, please follow the steps above, except for in step 2 you will want to click on the red arrow next to the "SOFTWARE" section instead of the RECOMMENDED FOR YOU section to locate and download the software. If you plan on using the printer wirelessly, please be sure to install the Canon IJ Network Tool last after all other software has been installed.


Once all items have been downloaded, please double-click on each of the items on your Mac to install them. 


Hope this helps!


This didn't answer your question or issue? Please call or email us at one of the methods on the Contact Us page for further assistance.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

OK, I went through the steps of deleting the printer, reinstalling the drivers, etc., and even though I can still print, I get the exact same message error I did before when I try to scan.  


Please provide another suggestion.  Thanks,


Still need help!

Hi ktbills!


Per Ramona's previous message, we ask that you CONTACT US for further support.


Thanks and have a great day!

Isn‘t there a general solution for this error message? It would be helpful to all users to see it published here in the forum. I just ran into this error as well. I installed the Canon software from the cd under my admin account. Then logged into my user account but got this error. 

The scanner is not available while in use by another application or user 2.249.0


That is another annoying UX experience after I got so disappointed when I learned that Canon rejected updating drivers for my fabulous 8000F. 

Btw. I updated the drivers as well from the Canon website, still no luck.

Had this problem last night. Canon support couldn't fix it. They advised that I contact Apple. Using El Capitan 10.11.2

Long story short. Unplug Printer/scanner ( I'm using a Pixma MX 922 ) leave unplugged for about 15 minutes to clear. Then reconnect to access point. You should be good to go.

Well, my problem fixed itself.  I never did find time to have an extended call with Canon support.  So, I used my old 8600f flatbed scanner when necessary, which still worked, and then a year went by...


Then, it happened that I upgraded to El Capitan OS on my iMac, and while I was at it, went back and updated the driver (which I had prevously done a year ago for my old operating system without fixing the scanner issue) for the MX922 to the latest driver for El Capitan, and surprise!  The problem was gone.  I still don't know what happened to fix the problem -- the change in computer operating system, the driver update, some power failure or internet outage or something else over the past year?  Wish I did know, but for now it is working...

Had this problem also...Went into Activty Monitor and stopped the Image Capture Extension process that was running. Restarted MP Navigator and scanning worked.