cancel
Showing results for 
Search instead for 
Did you mean: 

Pixma TS9120 Won't Print

GarryL
Contributor

 

I have installed the program 2 times once from disk and once from online installing program. I have deleted and reloaded MPdrivers as per instruction from Canon site. On computer in the settings/Devices/Printers, it shows the the printer is located and functioning properly. When I try to print from any program, it appears briefly in the Queue window then disappears. The queue tries to connect, but then goes to "Printer not Responding".

I sent a command to the printer to scan and print... It scanned, but didn't print. The window popped up to save it to a folder on my computer, and that worked fine. I am wanting to print directly from computer to printer. I am not wanting to use the wifi or a cell phone. Everything appears to be working except for the PRINT command from the computer. The screen on the printer has 3 icons, i.e., "Copy, Scan, and Print. When I click on the Print icon I get 3 more icons, Memory card, cloud and templates.

When I run the trouble shooter ... On both Windows 10 and the printer ... It comes back ... "Troubleshooting couldn't identify the problem". I am at a loss. HELP!



18 REPLIES 18

pwrichcreek
Enthusiast

Hi GarryL,

I sent a command to the printer to scan and print... It scanned, but didn't print. The window popped up to save it to a folder on my computer, and that worked fine

1. What program/application are you using to do the scan and print?
2. Can you capture the window that pops up to save it to a folder?
3. Run it again and see if there is a job waiting in the print queue

>To view a list of items waiting to print in Windows 10, select the Start  menu, then type printers and scanners in the search    box on the taskbar.
>Select Printers & scanners and select your printer from the list.
>Select Open queue to see what's printing and the upcoming print order.

Nope .... I can't scan from the computer ... I have to scan from the printer ... the only way I am able to save it is as a pdf file. Then when I go to print it, it goes to the queue for a second and then leaves/ The computer tries to gather the status from the printer, but is unable to do so and closes.

 

GL

GarryL,

 

Are you using the display screen on the printer/scanner that shows Copy Scan Print? And pressing Print?

 

When I do that it shows me a screen that says Memory Card Cloud Template. I don't know what that means, but seems that if it was designed to print from the scanner, it would give me that option. When I then press Cloud it says Commuicating then eventually shows Number Place Facebook Instagram.

 

But the item you want to print is in the scanner, right?

 

I don't have a TS9120, mine is a TS8120, Perhaps that is why I don't get a message that says "printing" that you describe.

 

You say you can't scan from the computer. I take it that, by that, you mean you don't have an application that you can run on the computer that claims it will create a pdf?

 

I'll see if I can find some other resource where I can look for TS9120 issues (and, hopefully, solutions).

 

Phil.

GarryL,

 

I use a program called IJ Scan Utility to create pdfs from the scanner. It's capable of combining multiple documents into a single pdf and, of course, from  a single document. Use the following link to download it.

 

WARNING*********************************************

If it ever asks you to uninstall "the drivers", DON'T.

The uninstall will automatically, without informing you,

that it is going to restart your computer. Instead, just

do a re-boot on you own, when you've had a chance

to prepare to re-boot.

*********************************************************

https://support.usa.canon.com/kb/index?id=ART137999&page=content

 

Please let us know whether or not this works.

 

Phil.

Christinadina
Apprentice

Hello - 

I hope it's ok to bump this. I have the exact problem and I don't find a resolution. I'm hoping that if I clarify/respond to some of the above feedback & questions, someone will have some suggestions. 

 

To recap: Printer has a wireless connection. This model is supposed to scan, copy, and print. Scanning works as it should; i.e., the document is scanned and the image is sent wirelessly to my computer. HOWEVER, when I want to try to print any document, it goes to the queue and after a short wait, there's an error message saying printer not responding. 

 

How is it that the signal is going from the printer TO the computer, but the signal isn't going FROM the computer to the printer? 

 

My printer was working fine until I had a new router installed. I followed the setup prompts for wireless LAN. Got message saying connection is done. Troubleshooter says everything is fine. 

 

Going back to what Garry described above, when I touch Print on the printer screen, I am offered 3 options - print from Cloud, USB, or Templates. IT USED TO SAY PRINT FROM COMPUTER but that icon is not on the screen now.   EDIT: I've realized there never was a 'print from computer' icon. You just print from your computer without selecting any icon. 

 

I'm not sure what to check next. 

 

Thanks in advance for any suggestions. I'm really frustrated!

 

 

Hi again 🙂

 

I did some more digging online and found a youtube video that helped me solve the problem. Short answer is that I created a new TCP port that matched the IP address of my printer.

 

I kind of stumbled upon this, so I'll share what I did for anyone who might also need this info. 

 

First I located my printer LAN settings and printed them out. 

[touch the wifi icon: Yes ok to display password: LAN Settings: Wireless LAN Settings: WLAN setting list: Yes ok to print/display password: Print details]

 

Under item 3 Wireless LAN on my printout I located my printer's IP address

I typed that into the address bar on my computer; from there I could see my ink settings and some other stuff so this confirmed that I had the right address.

 

Then I found this youtube video which basically showed how to go to your printer properties, find the port list, add a TCP port with the same address as the printer IP, and voila! 

 

Here's the video: https://www.youtube.com/watch?v=CE-8SqjC7nM

(FYI - The video is for an HP printer but it still worked.) 

 

Tested from my phone - that worked.

Tested a scan - that worked too.

 

Hope this helps someone. If some Canon person (or anyone else) can explain why I got the problem in the first place, that would be great too. 

 

I have a Pixma TS9120 and I have been having a lot of trouble with not being able to communicate with my printer from my computer. This comment about the IP addresse resloved all of the issues! Thank you very much for this info!

I found the best solution was to return the printer and buy one that easy to work with and the instruction were written so someone that wasn't a techy could work on and understand. I bought an Epson, a great piece of equipment and easy to understand instructions.

I wanted to thank you for your response. I've been scratching my head on and on for months not being able to resolve my "printer won't respond" issue. Once I added a new port, everything started to work again. Yippee!

 

Announcements

08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x