cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma MG7120 not printing MS Office Documents

JoeFW
Apprentice

This regards Pixma MG7120 multi-function printer, bought 8/17/2014.  Running on Windows 10.

 

I tried unsuccessfully to reach anyone live at Canon, where I could discuss this.  Phone 800-652-2666 is what I found for Canon Tech Support.  There, I get a question about the phone number used when I first registered my product.

A Canon email dated 12/14/2014, pertained to certain printing matters; it cited my home phone number, my landline.

 

When I enter that phone number, the system says that number is not in Canon records; but does not accord me any opportunity to speak with anyone.  I feel sure that is what I used when I first got the printer; but, the system also does not like the cellphone numbers for my wife & me.

 

THIS IS NOT "AWARD WINNING CUSTOMER SERVICE, touted by Canon!

 

 

Here is my problem: We have an HP laptop with software loaded for the Canon printer.  Using that, we previously  printed successfully, pretty much anything.  To best of our knowledge, no settings changed in recent months.

 

In recent weeks, MS Office 13 documents – Excel & Word – have not printed.  In print pre-view, we see no numbers or text.  All we see is any color background.  We CAN print PDF files and web items.  I uninstalled and reinstalled the Canon program; no joy.

 

NOTE: The same software works OK with my desktop PC.  The issue is solely with the laptop.

 

Please help!!!

 

3 REPLIES 3

shadowsports
Legend
Legend

Greetings,

Since you can print .PDF and webforms, and have the printer functioning on another system normally it appears the issue is related to the HP laptop and its software environment. 

 

If Office is the only software exhibiting the behavior, I would suggest running a repair install of the Office Suite.

 

Control Panel > Programs and Features > find the Office suite listing a right-click > select "change > then Repair

 

Good idea to restart the system after running the repair, now retest.

 

repair.png

 

I understand you are looking for help, but this is clearly a problem with the OS or software environment, and not the printer.   

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

VOILLA!  Worked like a charm -- did have to re-boot to take effect.  Cigars around!

Thanks for your feedback.  Glad this worked for you.  

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Avatar
click here to view the gallery
Announcements