Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma MG6620 Won't Turn On


Apparently there has been something Canon has updated today or over the weekend which has caused a variety of users to experience the exact same problem - printer decided to power off and won't power back up. You cannot tell me that it is just a coincidence that all of our hardware drivers crashed at the exact same time. I am not buying a new printer when mine worked fine a couple of days ago before Memorial Day weekend.



This started tonight on my MG6620 also.  Turn the printer on, stays on for a few seconds then shuts down.  Never get the printing screen to come on and not able to get into the settings to reset them.  Tried a few time to reset to no avail.  Funny I was printing away just last night!

Same thing happened to me as well. Did you try to unplug your internet and then try to turn your printer on? I could not get it to even load to the start menu until I completely unplugged my internet and wifi then miraculously I was able to turn my printer on. If I plugged my internet back in as soon as the printer detected it, it would shut down the printer and I could not turn it back on. I ended up unplugging my internet and once printer was on I went into the printer settings and reset it back to factory so it can no longer access my internet. Now printer works perfectly again via a usb cable. I am not happy because I wifi print a lot but it will do for now. 

I will try that later tonight after I don't need wifi or early morning.  Hopefully I can get it to work with usb.

This is so frustrating! Mine was working fine as well on a friday then by monday poof nothing. I use this thing working from home. We shouldn’t have to replace our printers for something like this and of course I just bought more inkjets!

Have you heard of a better fix than what they are telling us?

I tried what they said to do and the printer doesn’t stay on long enough to even see the screen to change any settings

Make sure to turn off your WiFi first and then the printer should turn on . Canon issued a firmware update, did you see that?


Something has to do with the Wi-Fi connection. I tried all the work around the Canon MG6620 keeps shutting down, I tried powering off my home Wi-Fi, and when I turn on the device, it works. Then, I reset to the factory defaults setting to remove the Wi-Fi setting on the printer itself. I turned my home Wi-Fi and tried powering on and off my printer with no issue. The only thing is it's not connected to Wi-Fi. Once I connect to Wi-Fi, it starts shutting down again. So, I ended up resetting again to be able to use the need to connect directly to pc/laptop and not the Wi-Fi Canon need to fix the issue seems they are just trying to make us dispose of our good printer to buy a new one.

Thank you! It worked to get my printer running again. Looks like I have lost the WiFi connection, but can still print and use up the ink I just bought. I didn’t get to do the factory reset…so I am afraid to turn it off and have to start over. That is for another day. None of the instructions on line seemed to work for the MG6620. 


I have the MG6620 and doing the same thing!


SOLUTION: After a 1:57 hold time with Canon customer service.... I have the solution! (and that was 2 hours, not 2 minutes) If this is happening to you it is very easily fixed. [Removed per Community Guidelines]  Although I wish I could make up for my 2 + hours of time. The tech told me that when they walked into the office Tuesday morning, "the stuff had hit the fan" because this has affected many models and they don't know what caused it. Here is what you need to do to fix it:

Completely unplug your router and then turn on your printer (it won't stay on if your router is because of a linking problem with the router, that we are going to fix.)  So this is the step-by-step for the MG6620 and probably those models with similar menus, but whatever model you have just try to get to your DNS Server Setup. That is where the setting is that needs manually changed. So for the MG6620:

On the menu swipe to Setup, then find Web Service Setup then DNS Server Setup. Select Manual.  Press each set of numbers and change them all to 000 except the last set. That needs to be 001. So your DNS will look like this:  Click OK, then click No.

That's it. You should be good to print.

You are welcome!  Too bad someone at Canon doesn't just post this somewhere. Would've save a lot of people a lot of headaches, I'm sure. 

Thank you! Your solution or wherever you got it worked like a charm.  I owe you a coffee at least!


click here to view the gallery