cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA mx-922 Cleaned encoder strip but still double printing letters

pocketlamas
Apprentice

I'm on Windows 10 if that matters. The printer is running on Wi-Fi.

 

Every one to three lines of text is sharp all the rest is blurry. This happens with printing and copying.

 

I've done a deep cleaning of the nozzles and I've cleaned what I could of the encoder strip with a swab dipped in alcohol and wiped it clean with another  swab.

 

 

 


The probem continues.

2 REPLIES 2

Patrick
Product Expert
Product Expert

Hi pocketlamas,

 

Please try cleaning the encoder strip again.  Any smudges on this would cause the poor print quality you are experiencing.  If the issue persists, your PIXMA MX922 would require service. You are eligible for Canon's Upgrade Program.  This is for out of warranty units which have been diagnosed to require service, or for some reason are incompatible with a new or upgraded system.  This option allows you a one-time opportunity to purchase a replacement product, discounted from the list price.

 

To help you get up and running quickly, we also offer free standard shipping (if the order is completed by 12:30PM ET).  If you would like to take part in this option, please call our Sales Department at (866) 443-8002 seven days a week, 8am to Midnight.  Let them know you have been working with technical support and the Canon Upgrade Program was offered.

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Dolmes
Apprentice

My experience with this problem doesn't make much sense but here it is. My problem with double printing is now resolved.

I had been having this problem for 2 years, like every 3rd line would be double printed. The PGBK part of the Print Nozzle Test Pattern test would have all vertical lines as being double. I bought a used MX922 on ebay but it has the same problem as my old one. I bought isopropol alcohol and swabs and attempted to clean the timing strip on my old one. Extremely difficult to do due to very restricted access to the strip and I felt I had not done it very well. Nothing I did had any affect.

Reading on the web I saw instances where some people had resolved the issue by replacing the print head. So I decided to really clean the print head. I followed easy removal instructions by this guy ( https://www.youtube.com/watch?v=9-qlcZ2ekvk ). After removing the print head I also removed the 2 screws holding the actual head (white) to the carrier to clean better. These 2 screws are VERY hard to remove so pick your phillips screwdriver size carefully so as not to strip the screwheads. Cleaned with both hot water and alcohol. After drying overnight the cleaning had NO effect on the double printing. Decided the clean the head on the ebay machine also. After the cleaning the ebay's test sheet still showed it was doing the same double printing as before also.

I then decided to swap the print heads so the ebay print head is now in my old machine and amazingly the double printing is GONE. I have no idea why.

I am getting some banding in the blue color on color copies but I did not take as much care in cleaning the ebay print head and it had been sitting a year and a half without being used and no telling how long it sat before I got it. I will do a heavy cleaning process later. By the way I cannot find timing strips for sale anywhere for the MX922. Also I have seen no mention anywhere of whatever it is that READS the timing strip.

Avatar
click here to view the press release
Announcements