Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA Problems w/Chromebook


My Pixma MG3520 used to work with this Lenovo Chromebook--I bought it specifically bc it was Cloud Print Ready. Recently the printer has been freezing up with BK messages despite adequate ink supply and I thought that was why it wouldn't print, but it copies fine, the printer is "offline" and I can't seem to restore it. I'm pursuing help with Chrome but no luck so far, and their setup page is nonresponsive in the same way the email form at Canon is. Very frustrating, but I have to believe there's a way to reunite these star-crossed appliances. Help? Thank you! 




MG3520 - ChromeOS is not a supported operating system:


Windows 8, Windows 7, Windows 7 SP1, Windows Vista SP1, Vista SP2, Windows XP SP3 32-bit, Mac OS® X v10.6.8 - 10.9.x.  Windows 10 is also supported.


Instuction for addind printers to Chrome OS:


The SELPHY App is another alternative:

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Just to be clear, it was at the time I bought it, and it worked fine for three-plus years. Do you mean they've simply stopped supporting it? If so, is there a patch or workaround? I'm poor and need this setup for a lot of paperwork. 

Hi HLSeggel,


You can use your PIXMA MG3520 with your Chromebook.  First, please press and hold the STOP button on your printer until the Alarm lamp flashes 15 times, then let go of the button.


The Network Configuration page will print.  Is the SSID listed match the wireless network name that your Chromebook is connected to?  If so, please take note of the IPv4 IP Address on this page.


On your Chromebook, please open the Chrome web browser.  Type in the IPv4 IP Address of your MG3520 in the address bar of Chrome and press the Enter key on the keyboard.


Log in to the user interface of your MG3520.


Click Google Cloud Print Setup on left side


Click Register with Google Cloud Print


For more information regarding this process, please view the following PDF:








Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks. Someone called and walked me through this process but it didn't work. I got a "Congratulations! Your printer is now connected" msg, but behind it the screen said "Communicating..." for AGES, and when I tried to print once again the printer was not connected. I think my best bet is downloading to USB and printing at the library.

Thanks but, as I stated below, I tried this and it did not work. Looking at giving up the MG, keeping the iP2702 for my very old Dell, and mostly taking a USB drive to somewhere with decent, connected tech.

I am having the same problem. I printed out the network configuration page and there is nothing listed to the right of the IPv4 Address, it is blank.

Both my Canon printers are sitting on the floor while I look for a way to get them to an e-waste pick-up. Super bummed, I used to at least be able to scan to a Windows XP laptop and now even that's not working. Sorry to hear you're having the same issue.

Hi etate42,


What model Canon printer do you own?


On the network configuration page that you printed, is your home's Wi-Fi network name listed next to SSID?





Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
click here to view the gallery