Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MX452 Filter failed error with new macbook




I'm an older technically challenged guy who's having a difficult time attemping to connect a new Apple Macbook pro to an older mx452 printer.


I'm operating osMojave version 10.14.5.


I installed the driver from the Canon website.  When attempting to print, the printer acts like it's going to print and then I get a "filter failed" message.    The apple website mentions something about 32 bit and 64 bit but also says Mojave is the last operating system still using 32 bit.  


Can anyone help?






Product Expert
Product Expert

Hi Smokeymac2,


Please follow these steps:


 1.  Click on the Apple in the upper left hand corner and then System Preferences.


 2.  Click on Printers & Scanners.


 3.  Click on the Canon printer on the left side and then the [-] at the bottom to remove it.


 4.  Repeat until all Canon printers are removed and then close System Preferences.


 5.  Click once on desktop so Finder appears in upper left corner.


 6.  Click on Go and then Go to Folder.


 7.  In that box, type:




and click Go


 8.  In the folder that appears, please delete Canon folder.


Once removed, please close all window and then open a web browser:


 1.  Go to:


 2.  In the enter a model box, please type MX450 and click on PIXMA MX452 that appears below it and click the GO button.


 3.  On the PIXMA MX452's page, please click the Drivers & Downloads button.


 4.  Click the Select button next to "MX450 series CUPS Printer Driver Ver. (Mac)".


 5.  Click the Download button.


 6.  Once the download is complete, please open your downloads folder.


 7.  Double click "mcpd-mac-mx450-16_20_0_0-ea21_3.dmg".


 8.  Double click the new disk image on the desktop to begin the installation and follow the on screen prompts.


 9.  Once installed, please click on the Apple in the upper left corner and then System Preferences.


10.  Click on Printers & Scanners.


11.  Click the [+] at the bottom and then click on Add printer or scanner.


12.  In the Add window, please click on the Canon MX450 series 1 time.


13.  At the bottom, next to "Use", please make sure Canon MX450 series is selected.


14.  Click Add.


Once added, please attempt to print.





Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Patrick, Thanks so much for your reply.  Before I start the process, I have successfully added my wife's printer which is a Canon MG7520.  (I was tickled that I got it to work)  If I delete all canon printer files it will, of course, delete that mg7520 printer.  It took me an hour to find the right combination to get her's to talk to my computer and I am hoping I can avoid that again.


Is it possible to just delete the files for my mx452 and continue the process without deleting the other printer as well?


Thanks in advance.

Hi Smokeymac2,


Yes, you can try that first.




Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I updated to Mac OS 11.1 today.  When I try to print I get the message Filter failed error.  I followed your directions and delete the printer. When I tried installing the driver from Canon I get an error message that it can't install on this version of the operating system and to run the installer on a version that supports it.  I guess I'll contact Apple to see how to revert back to the previous version.

@Rusty629, I had the same error saying that Apple couldn't scan the software for malicious bla bla.  Just Ctrl-click the pkg file that you were trying to install.  Then click Open and Open again when it asks for confirmation.  This will override the warning and I'm now up and running again on OS 11x Mojave.

Just wanted to add thank you so much! I was having this same issue, did exactly as you described and voila! Working again. It was driving me mad, I was about to throw the printer the curb. Again, thank you!

Thank youThis worked! I didn't even have to install the online software! eleting the old Canon file in the Library/Printers folder solved the problem. When I did that and THEN tried to print the system auto! matically installed Canon printer software that would work with the new laptop.

now all I have to do is fix the weird script on my laptop that doesn't seem to correct here when I ask it to correct. hahaha! Delete not elete.  lol.   

Hi Patrick,


I completed all the steps and unfortunately still get the same 'Filter Failed' message. 


This is for the ImageCLASS D530 and when I look at the driver I supposedly am downloading and the one that is installed, they don't match.


Per my computer, the Driver Version is 10.11.3

Per the download from the website it show 10.11.6 last updated 12/09/2020


So, that's my guess, I've gone through the steps twice now and restarted.


Any other thoughts I might be missing?




I'm running a Mac BigSur - 11.1

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th