Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA MP250 I need help with a print spooler error message


Out of the blue I lost my printer connection.  When I look at my printer menu there is no printer listed.  When I try to add or install a printer, I get some odd message about a printer spooler is not running.  Restart the machine.  I've tried unhooking the printer, rebooting, unhooking from the power source.  I even went into some area as an administrator and found the print spool task and when I clicked on the start button there was no action.



This is a MS Windows issue. Try this:


Right click on My Computer

Select Manage

Double click on Services and Application

Double click on Services

Scroll down to Print Spooler and double click on it

Click on Dependencies tab

Check what dependencies the print spooler has, if any you may need to click on + on those dependencies to more dependencies

Go back to the Services list

On each of the spooler dependencies, double click on it

Make sure it is set to Automatic in the Startup Type drop down menu

Now click on Start to start the service

Click OK


Now try and print.



Hello Kendra!  In order for the community to better assist you, we’ll need to know the model of the printer you are using.  This will ensure the most accurate information is provided.  Thank you and have a great day!

Hello Jason,


I actually just ran into this problem myself and while looking for an answer, I ran into this post. I have a Pixma Canon MP250 and I also have Windows 8.1. Is there a way to fix the spooler problem so that I can use my printer once more? It's so weird because I was using it just yesterday and today out of the blue it stopped working and I have no idea whatsover what 'caused it. Any help would be greatly appreciated! Thanks in advance.


-- Maria



The Print Spooler service is a Microsoft service.  This has to be running properly in order for printers to work.


If the service is being stopped, please contact your computer manufacturer to investigate what is stopping the service.


This didn't answer your question or issue? Find more help at Contact Us.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


Printer Spooler Error Message:  I found that by going into the Windows Control Panel, then selecting:  "Program and Features" you will see the heading on this page: : "Inistall or Change a Program" ... to the left of these words on this same page,, you will see a small Windows Shield and the wording:  "Turn Windows Features On and Off."    I then selected that option and then, within that option, went down the alphabetic list to:  "Printer and Document Services"   -- In my situation, the Printer and Document Services box along with the related services boxes below were not checked.. just a dot mark.. My printer and computer had been working just fine.. how this got changed is not understood.....  


I made certain all boxes under Printer and Document Services were checked and then my printer started to work and the "Printer and Spooler Error Message" went away.... In my stiutaiton this appeared to be a Windows problem not related to my Cannon MP280 printer which works just great for me...!   

Thank You!! Your steps worked perfectly so strange that this happened...


I found a solution to the print spooler. I have an android phone and that may be all this works for. Under my print options when I have my page ready to go, there's printer defaults I had 2 printer defaults running ( canon and the phones default print software). Turn off the phones default. If you ever get another print- we'll turn it back on or your new printers app as default. I'm not a super geek by any means so maybe this can help/maybe not. GL

Greetings ,

Since this is an 11-year old topic, it's likely the issue you experienced, and solution offered differs greatly from the individual who started this thread.  If you would like assistance, please start a new thread. It should include the model number of your Canon device, the version and build of the operating system you are using, what your device is connected to and how. Please include any additional information or errors you have encountered or believe will help us better understand your issue.  There is just too much which has changed since this thread was started.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It


I also have this problem with my Canon printer. But unfortunately I was not using windows to print.

Enter for a chance to win