cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX 727 Unresponsive

crouchie
Apprentice

Bought my new MX727 the other day seemed to set up ok - used it a fair amount in the first few days. Culminating in some photo-copying. Following day I cant seem to print anything - just sits in the out queue and never actually prints - the queue says its connected to the printer, but nothing happens. Same issue when trying to print from my iphone - although the printer is visible on the iphone nothing happens (previously I successfully printed this way).

 

Tried to reset the network on the printer menu (I'm connecting tho the printer over wifi network which worked really well the first few days), but when I got to the menu on the display it just kept searching for the network.  Other times the display gets stuck on say fax function and the device becomes unresponsive to any of the buttons.

 

When I try to shut down it gives me an "ending...please wait awhile" message for about 30 mins.

 

I read an old post on this forum that suggested:

 

"Unplug the printer, then press the power button 5 times.  Wait for 30 minutes and then reconnect the power.  Turn on the printer.  Wait a few moments for the printer to reach the home screen and then power off the printer.  If it powers off properly, try a test print or reinstall the printer"

 

This did not work however...tearing my hair out. Have re-installed all drivers. Any ideas???

1 REPLY 1

crouchie
Apprentice
Have just now connected via USB to the printer. Deleted the device from my printers list on the laptop. Waited for my macbook to 'see' the USB connected device, re-installed the printer. While still connected on USB, tried to print again, but nothing - print queue says "printing", but nothing doing on the actual printer itself.
National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements