Showing results for 
Show  only  | Search instead for 
Did you mean: 

MG3620 Stopped Working


My MG3620 was working perfectly yesterday, but today it stopped working. Important note is that I don't have router in my apartment. The wi-fi is provided by the building, and each apartment has own wi-fi connection (e.g. I connect the wi-fi named as my apartment number, but I don't have access to the actual router).

My computer (Mac) showed that printer is offline. When I opened my PRINT app it couldn't print either. 
I tried to troubleshoot and do the network set up again, but it didn't help either and stuck in loop.

The steps I took:

1. I chose file I want to print (using my iPhone).

I get the message it can't be done, failed communicate with the printer. Suggests me check location settings, I did, they are up to requirements.

It shows me list of actions to do, e.g. restart printer, restart router (which I cannot do), and other stuff, none of which helps, unfortunately. Once I chose all of them and proceed further, next screen offers me 3 options 'Okay', 'Settings' to update location settings, and 'Restore Network'.

Okay does nothing, Location settings are fine, so I can only do something with Restore Network.

2. I click Restore Network.

Next screen asking me if I prepared my printer, the link on how to prepare printer tell me I have to press Wi-Fi button until my Power button starts to blink, once it does I must press Color button, and Wi-Fi button again. The power light becomes steady and Wi-Fi starts to blink. The instructions say it must blink fast, but it doesn't blink fast, it just blinks. Sometime the light disappears for a second, does 2 fast blinks and then stops for a second again before it does 2 fast blinks.

3. Then next screen tells me that I must be close to printer and that it will try to connect to it. I do exactly what it asks, the phone asks if I want to join some wi-fi network, and I connect to it.

4. The next screen asks me to choose my Wi-Fi network, I choose one, I put in the password, it thinks for a while and shows me the screen asking if I restarted my device. I didn't actually restart anything, I guess this is where the trouble of communication between devices happens.

5. I never had printer set up on my computer, I tried installing drivers for it and other IJ software, but nothing connected.

6. I did some other magic, by holding some other button and counting 21 times for the 'danger' button to blink, then disconnected printer power cord for 10 minutes > didn't help either.

7. I deleted the PRINT app from my iPhone, installed it again, tried adding printer > it stuck on the Search Printer

What do I do? Send printer back or is there a way to fix it?