Showing results for 
Show  only  | Search instead for 
Did you mean: 

MG2200 stopped printing browser pages


My father has a MG2200 scanner/printer attached to a laptop running Win10.  He started having issues printing first with OpenOffice word and then with web pages including webmail.   From another forum I learned that sometimes removing then adding the printer will solve the problem for OpenOffice, and it did.  However the inability to print from a web page continues.


I downloaded the driver from and installed it.  Tried removing/adding the printer again.  Tried different USB ports etc.  This had not been a problem before.  He uses Firefox browser.


Thanks for any assistance.



You've done a great job telling us about the symptoms...  but not what actually occurs when you try to print.  What happens? 


Press print and......  ???


Nothing comes out?

Error displays?

Page prints blank?... 


Do all print jobs fail to print?


Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Oh my goodness, I apologize for the oversight.  Fingers working faster than the brain!


When he prints, it will send out only a blank page if the print request was a webpage.  If it is from an email out of his webmail page (Outlook), it sometimes just prints the Subject line or a blank page.  This has been a consistent problem since it started.  I don't have the date it started or what else may have occurred just prior.   I have my father's computer set to update automatically.  (Caveat:  My father is 83 and I am accessing his computer remotely and he is having to tell me what the print result is.  So there is a slight chance that I do not get all the details but I'm pretty sure everything reported is correct.)


When OpenOffice was not printing, it also would just send out a blank page.


The Print Test Page works and has worked consistently each time I tried it during troubleshooting


Again sorry, thanks.


Thanks, Thats a bit more helpful.  Removing and re-adding the printer was a good first step.


You said this fixed printing from Open Office.  What happens if he tries to print web pages from a different browser?  Edge, IE (both present in W10) or Chrome if he has this installed too?


Maybe this is a problem with the latest version of FF?  If he cannot print from Edge, IE or Chrome... continue


-Have you confirmed the printer has ink?  All cartridges have 10% or more ink remaining?

-Have him unseat and reseat each cartridge, then power cycle the printer and retest

-Ensure he has "Plain Paper" set as the papter type, retest printing


Windows start menu > Control Panel > Device and Printers > right-click on the printer and select printer properties (middle of the context menu) > Select Advanced Tab...  what is listed as the driver?


Will wait to hear back. Since test pages work and so does Open Office, I think it might be FF.  If there are any areas in the printed page that are missing colors, then their may be a blockage, but am leaning towards FF at the moment.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It



I was thinking about refreshing his FF.  I'll try a different browser as well.


He's out of town right now so I'll have to wait to set up another remote session with him and then get back to you.


click here to view the gallery