Showing results for 
Show  only  | Search instead for 
Did you mean: 

Ink not flowing, empty ink tubes, G3260 MegaTank


The yellow stopped printing halfway through a photo on my G3260. After letting it rest for awhile, the yellow came back. I Googled for answers and found many Youtube videos showing Canon MegaTank printers with empty ink tubes. I looked under my hood and saw ink only in the black tube (see photo). The 3 colors were nearly empty even though all of my ink tanks are still over 90% full. (This is still the original ink).

The two most popular fixes I found for this problem are: 1) doing an Ink Flush or 2) drawing the ink back into the lines with a syringe (which doesn’t seem feasible on the G3260). I am hesitant to perform an Ink Flush because of the amount of ink that is wasted and prematurely filling the maintenance cartridge.


1) What causes the MegaTank ink tubes to run dry? Is this an inherent problem to MegaTank printers?

2) What is the best fix for when the tubes are empty?

3) Can I abort an Ink Flush mid cycle when the tubes are full to save ink (and avoid overfilling the maintenance cartridge)?G3260-InkTubes_5672.jpg


Product Expert
Product Expert


I recommend reaching out to Canon support for real time support with this issue. You will need to register your Canon gear HERE to access additional support options.

We look forward to hearing from you. 

Unfortunately it's over 1 year old with a 1 year warranty, so I expect Canon to charge for support. If I can't find any clues on this forum, I'll just do a flush and try to stop it as soon as the tubes fill. I've had several Canon printers over the years (laser and inkjet) and they've all been great. This is the first one that isn't working flawlessly.

Jpady, did you ever get this fixed? I have the same problem.  Canons reply to your thread was weak.


I had a user with one of these printers that quit printing with error code 5200. It gave vague info on what that error meant. The suggested troubleshooting of cleaning the print head and doing an ink flush didn't work. Upon closer inspection, I saw that 2 of the 4 ink tubes were not filling, even though all 4 tanks were full. I don't know exactly what actions fixed it, but I repeatedly opened and closed the tank lids in the event that "vapor lock" could possibly form in the tanks. Then I did a little "percussive maintenance" by banging on the sides, front, and top of the printer to dislodge any air bubbles that might be blocking somewhere or possibly to get ink to flow down to reach any pumping mechanism. After this, I repeated the ink flush procedure. This got one more tube filling, so I repeated all these actions once more and all 4 tubes filled and the printer worked again.

click here to view the gallery