Showing results for 
Show  only  | Search instead for 
Did you mean: 

I am getting a "The scanner driver supported by this software is not installed." error.


I am getting a "The scanner driver supported by this software is not installed." error. I have a Canon MP 160  printer running on a Windows 7 64-bit PC. I have installed the mpnwin303ea22.exe. Please advise.



Hi jenbub1,


We recommend uninstalling the current drivers and MP Navigator program, then reinstalling them to try and resolve the issue.  To uninstall the current printer drivers and MP Navigator from your computer, please follow these steps:


1. Go to your START menu, and CONTROL PANEL.


2. Select the UNINSTALL A PROGRAM option under the PROGRAMS section.


3. Locate your PIXMA MP160 in the list and select the UNINSTALL option.

4. Press the EXECUTE button, and if prompted if you are sure that you want to uninstall the drivers, please click on YES. 

5. The printer drivers should begin uninstalling. Once uninstallation is completed, please press the COMPLETE button to finalize the uninstallation.


6.  Please follow the steps above to also locate and uninstall the MP Navigator program.


Once the drivers and MP Navigator program have been uninstalled, please install the latest drivers and version of MP Navigator for the printer from the Canon USA website.  Please click here to go to the initial download page for your PIXMA MP160.  Once on the initial download page for your model, please do the following:

1. Verify that the operating system detected in the "OPERATING SYSTEM" drop-down menu is correct, and if it is not, please click the drop-down menu to select your operating system.

2. Next, please click on the red arrow next to the "DRIVERS" section and click the MP drivers file. When you do, a red DOWNLOAD button will appear. Please click on the checkbox below the DOWNLOAD button, then click the red DOWNLOAD button to begin the download. The time for the download process may vary depending on the speed of your Internet connection and the size of the file being downloaded.

Once you have downloaded the MP drivers file, please follow the steps above to also download the MP Navigator EX program from the Recommended Downloads section.


Once both files have been downloaded, please double-click on each of them and follow the prompts to install them on your computer.  Please install the MP Drivers file first.

Hope this helps!

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I've been attempting to install / connect my new MX492 Printer for 8 hours now after my Older Canon MG5320 suddenly stopped working for no apparent reason and just gave message to contact service center?!!!


After 8 hours and countless Youtube videos I was finally able to connect the new Canon Printer but it won't let me SCAN. I keep getting the message: The scanner driver supported by this software is not installed.​"


So frustrated. Going back in the box tomorrow and will be returned.  So disappointed with Canon.


I've installed many printers to computers over the years and have never had this many problems, and it's obviously a problem others are experiencing.  What is up with Canon?  I truely thought it would be a quick 15 minute process.  Not 8 hours all for nothing since I can't scan.


Because of this inability to Scan I now have to drive 2 hours tomorrow from my desert home to my office in Beverly Hills just to properly scan documents that I was hoping to scan with my new inefficient Canon MX492.


Surely Canon can fix this problem. A Google search will reveal that others are experiencing the same problem as well.  Canon, your clients time is valuable.  I just wasted 8 hours of my time on a faulty inefficient Printer/Scanner.


Again, I've installed many printers. I've followeed all instructions to the letter. I've tried installing every way possible. It's not me... it's the Faulty Printer/Scanner.  Most other Printers install easily.  Why not Canon?


So dissappointed with Canon.




Hi, Danewood!

Thanks for posting on our forum! This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, contacting our US-based technical support team is the most efficient way to get these issues straightened out. They're standing by, ready to help 24/7 via Email at or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 10 PM ET (7 AM to 7 PM PT).

Thanks and have a great day!

I tried this solution.  Absolutely no effect at all.   Im using Windows 7 and the printer is an mp520, but Im getting exactly the same message


Hi Vanders,


Reinstalling your PIXMA MP520 will resolve this issue. To do this, please disconnect the USB cable from your PIXMA MP520 and then follow these steps:


1. Click on the Windows Start Menu button in the lower left hand corner.


2. Click on Control Panel.


3. Under Programs, click on Uninstall a Program.


4. Click on the Canon MP520 series MP Driver and then click Uninstall at the top.


5. Follow the prompts to uninstall the driver.


Once uninstalled, we will make sure that it has been removed:


1. Click on the Windows Start Menu button in the lower left hand corner and then the Windows System folder.


2. Click on Control Panel.


3. Click on View devices and printers.


4. If there are any Canon MP520 series printers in this window, place the cursor over it, press the right mouse button and then click the left mouse button on Remove Device.


5. Repeat this until all Canon MP520s have been removed.


6. Restart the computer once complete.


When the computer restarts, we will install your PIXMA MP520 again:


1. Visit Canon's website at:


2. Type PIXMA MP520 in the "enter a model" box and click GO.


3. Click on Drivers & Downloads.


4. Click the Select button next to "MP520 series MP Driver Ver. 1.01".


5. Click the Download button.


6. A File Download box may appear. If it does, select Save.


7. Once the download is complete, open your Downloads folder.


8. Double click [mp520swin101ej.exe] or [mp520swin64101ej.exe], depending on the version of Windows 7 installed on your computer.


Follow the prompts to reinstall your PIXMA MP520 on your computer, reconnecting the USB cable when prompted.


If you continue to have difficulties, please contact our support group using the following link:

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

so sad that all canon can give us it the old "uninstall, reinstall" montra along with factory reset your device and router. seriously canon! get some real tech support, and some software engeneers to fix this cronic problem with your installer!


spending a week tryng to reinstall a printer (past return period sadly), and have nothing more then raw port 9100 printing is just bad business. we pay for a MF printer, not just a little desktop printer. if you (canon) cannot figure out basic network printing, then STOP SELLING NETWORK DEVICES! i (we) did not pay large sums of money for a multi function network printer just to have ONE device connected to the usb port or raw port 9100 printing only.


wish i bought an hp or brother.



Me too!! On Dec 28, 2020!


I just bought the CanoScan LiDE300 Scanner and the Canon InkJet Print Utility App which is the user interphase App is not working. It gives me the message " A driver supported by this software is not installed". I have visited this cite and taken the advice to uninstall everything, whiich I had installed using the CD. I uninstalled everything and reinstalled using the online option. It gave me the exact same result! Nothing resolved. I had emergency scanning to do. I use a Windows 10 desktop. Eventually I noticed that I could scan if I accessed the scanner through Control Panel ---> Hardware and Sound (view devices and printers) and then selected the CanoScan LiDE300 scanner from the list of devices. Clicking the Scan Photos or Document button allowed me to do single page scans of my documents. Before I could do this I first the error message "Release the lock switch, detach the USB cable and reconnect. Scanner driver will be closed." and that was because I had not shifted the little lock under the scanner from the lock to the unlock position. 


So now I am getting single page scan jobs only. I am not able to do multiple page scans as any such more advanced functions are only possible through the Canon InkJet Print Utility App which is not working. 

I plan to call the helpdesk for Canon tomorrow and I hope they are working on Dec 29. I am so dissappointed so far, but I hope my post helps others to at least get some scan facility. What I had to do was copy my pdf scans into a word document an then convert that word document into a PDF document, but that is so much extra work!



You need to also install the MF drivers before the MF utility works

MFDrivers (Generic Plus UFR II / Generic Plus PCL6 / ScanGear)


for instance from this page (you will need the drivers for your printer model)

03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.