Showing results for 
Show  only  | Search instead for 
Did you mean: 

HELP PLEASE! blurry BLACK text printing PIXMA MG7120


My Pixma MG7120 Printer is printing all black text in blurry fashion.  I have cleaned in every way and even replaced the black ink.  Not sure what I am doing wrong or how to fix.  



Check your printer's paper settings. Switch setting to Photo Paper (even if you're using plain paper) , select MATTE Photo paper, save the settings. Now try printing again. In my case, my blurry print became razor-sharp with this setting on my Canon MG7520. You're using more ink, but worth it if your printing an important document or shipping label.

View solution in original post


That might work, however, I'm done with canon printers.  I've used them for almost 20 years, but always have to replace them every 3 years.  I switched to an epson ecotank with photo black and have never looked back.  They have a swapable ink waste tank and can print up to 13x19.  the images look almost as good as my canon pro 9000 with 8 inks, but that ink is so expensive, i don't use the printer as often.  so switch to the Epson ET-8550  13x19 or et 8500   8.5x11

worked for me the best
thank you

I just wanted to add that I followed the original instructions by Canon Support and it worked for me right away. 

Just received an email from canon that a solution was posted?! Noooo, a work around that uses double the ink at half the speed is NOT a solution. Not sure what triggered the email, but it’s time for Canon to at least admit there’s a problem.


I just went into the settings and did the 'print head alignment' thing. It worked for me. Wish I'd done it sooner!!

Suffered very blurred printing in black only on my MG5560  and thinking about buying a new one.  Tried alignments, deep clean etc. but no good.      After watching Youtube about taking out printheads,  using tubes and syringe with printer cleaner,  running print head under hot tap etc.    I simply took out ink cartridges,  dabbed a cotton bud dipped in hot water on the large print head, paper towel dry and presto,  perfect printing.   


Dear Friends,


you only need to change the paper type settings to matte photo paper, and leave the quality to typical. Nothing else is required.


By doing this your problem will be solved without using a lot of ink each time you print


worked on my MG5753 and will work on the whole MG5 series

Hi Dimitris_kak,


It's true that changing the paper settings to matte photo paper solves the problem, but I think it does use more ink - it certainly takes a lot longer than normal printing. Perhaps when you change the setting to photo paper it automatically uses a finer print quality.


Where do you change the paper setting to Photo Matte?

It may be different in your printer, but for mine I go into 'Printer Settings', then in the Printer Settings window I change Media Type to 'Matte Photo Paper', then Print Quality to 'High'.  If you leave the Media Type as 'Standard', you don't get the High option in Print Quality.


Enter for a chance to win