cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error Message is saying "Type of print head in incorrect. Install correct print head

nanciemd
Apprentice

I have tried resetting , power off, cleaned head.

Still errror message.

 

Printer in Over 2 years old.

Do I just need a new print head??

 

thank you!

100 REPLIES 100

Jason
Whiz
Hello nanciemd,

The community is eager to assist!  To ensure the most accurate information is provided, we’ll need to know the model of the printer you are using.  We look forward to hearing back from you!

Canon MP510

Michael
Product Expert
Product Expert

Hello pd.

 

Please try the following to see if we can resolve your issue:

 

1.  Open the cover of the printer.

2.  Remove all ink tanks from the printer.

3.  Lift up the gray locking lever on the side of the ink tank holder.

4.  Gently remove the print head from the carriage unit.

5.  Place the print head back in and lock the lever down.

6.  Place all of the ink tanks back in the printer.

7.  Close the cover and turn the printer off.

8.  Unplug the power from the printer.  Leave the power unplugged for about 5-10 minutes.

 

Plug the power back in and turn the printer on.  If the error persists, please contact our support group using the link below for additional assistance with this issue. 

 

http://www.usa.canon.com/cusa/consumer/standard_display/contact_us_consumer

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I have a mp 560  and I have the same error message. Please help

Hello Neva13,

 

If you've tried the procedures above and the error remains, please reach out to our technical support department through the link below for further assistance.

 

Thanks!

 

http://www.usa.canon.com/cusa/consumer/standard_display/contact_us_consumer

 

 

I am having the same issue with my Pixima MX712. I did call tech support and they recommended I buy a new printer. They had no other repair options other than removing the printhead, putting it back in and turning the printer off and on again. I already tried that per the software recommendations and it didn't work.

I've got the same message on my MP640.  From reading other people's responses it looks like this is not fixable and new printer has to be bought.  What a bunch of crapola!!!!  Not getting Canon again if this is the case

Thanks! This worked perfectly for me. I didn't have to power off, it just worked after reseating the printhead.

I have tried your suggestion of removing and replacing print head without success.

What next?

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.