Showing results for 
Show  only  | Search instead for 
Did you mean: 

EASY FIX if your printer won't turn on


SOLUTION: After a 1:57 hold time with Canon customer service.... I have the solution! (and that was 2 hours, not 2 minutes) If this is happening to you it is very easily fixed. [Removed per forum guidelines] Although I wish I could make up for my 2 + hours of time. The tech told me that when they walked into the office Tuesday morning, "the stuff had hit the fan" because this has affected many models and they don't know what caused it. Here is what you need to do to fix it:

Completely unplug your router and then turn on your printer (it won't stay on if your router is because of a linking problem with the router, that we are going to fix.)  So this is the step-by-step for the MG6620 and probably those models with similar menus, but whatever model you have just try to get to your DNS Server Setup. That is where the setting is that needs manually changed. So for the MG6620:

On the menu swipe to Setup, then find Web Service Setup then DNS Server Setup. Select Manual.  Press each set of numbers and change them all to 000 except the last set. That needs to be 001. So your DNS will look like this:  Click OK, then click No.

That's it. You should be good to print.

You are welcome!  Too bad someone at Canon doesn't just post this somewhere. Would've save a lot of people a lot of headaches, I'm sure. 




My printer does not show any DNS setting. Is there another name for that?

Mine was under 'settings' then 'web service settings'.   MG6620. 


After reviewing this and re-reviewing and attempting to decipher the logistical greek of a multitude of notices and instructions and many many hours of honest effort, I plan to take my printer up to the roof (if I can figure out how to do that0 and JUMP!!!

Thanks for all the assistance... Don't send the paramedics!


Too bad there is no help for figuring out DNS and how to get to that... wherever and whatever it is. I watched a tedious video that led down a rabbit hole into netherland and no closer to figuring that out. I'm not a geek or a techy nerd, just have an old fashioned, and still working, brain. Am now on a loong wait AGAIN for a Canon tech. We shall see.


THANK YOU! This worked. I took the printer out to my garage and hunkered down with a tractor between the house and the device. Turned off the wireless. Came back into the house to do the software fix. It worked great. Cheers! 😎


Thank you so much for this info .. I was going to go buy a new printer. This worked!! 


Thanks very much for your detailed fix instructions. Now works great again. I was going to do their firmware update, but didn't have a compatible cable. When I got a cable, I went back in to get their upload instructions and saw your post. Much easier.


Good info but didn't work for me. Printer is completely unresponsive.