cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon mg 3522 unresponsive

Sheryl7511
Apprentice
My canon printer was working fine for last 2 yrs and suddenly would not print but just spool the blank paper out. The online manual indicated I should possibly clean the rollers. I tried that several times and it didn't work. I then tried to reset the printer using instructions online. I tried holding the stop button for two seconds then holding the power button and stop button together and releasing the power button and then hitting the stop button five times. None of these things worked. I then unplugged the printer, hit the power button five times and waited 30 minutes and plugged the printer back in. That didn't work either. For some reason there is a light on next to the power button and there is a light next to the photo paper button. There is no sound or movement of any kind from the machine. I checked and no paper stuck in the machine either. I can't seem to turn the power off. The only thing I can do is unplug it and the machine goes out but when I plug the machine back in the light next to the photo paper comes on and when I touch the Power button on the machine comes back on. But there is no response of any kind when I touch the other buttons I don't seem to have an Internet connection at all and I'm just totally confused as to what I can do to fix this or do I just need to get another printer. No?
0 REPLIES 0
Avatar
click here to view the press release
Announcements