cancel
Showing results for 
Search instead for 
Did you mean: 

Canon MG7720 Driver Doesn't Show Up After Upgrading to Mac OS Mojave

SoonerFan
Apprentice

I just recently updated to Mac OS Mojave and I've been having trouble with several of my printers, including this one, since then. I called Apple and they had me reset my printers and everything showed up and worked again. Absolutely no problem. But when I had to do a restart, they disappeared again. However this time, software update showed a box that asked me if I wanted to download the latest Canon software for my printer. I clicked yes and it started downloading. Then, about halfway through, it stopped and said "This printing service is not available." 

 

So, once again, I did a printer reset and once again, I retrieved all my printers and they worked. But I have twice done a restart, and they disappear again. This is so frustrating and time comsuming! I've talked to Apple and they can't seem to figure out why this is happening. Two of my printers have been updated for Mojave, but I don't know about my Canon software drivers. Have they been updated for Mojave?

 

I know I'm not the only one who is having these issues, so please tell us what you know about Canon printer driver compatibility with Mojave.

 

Thanks in advance for the help! 

2 REPLIES 2

Ramona
Authority

Hi SoonerFan,

 

The PIXMA MG7720 is compatible with the Mac OS 10.14 Mojave operating system.  The latest drivers for the printer can be downloaded from the Canon USA website here free of charge.  You will want to download and install the CUPS and ICA Drivers from the DRIVERS section of the page, and the IJ SCAN UTILITY LITE from the SOFTWARE section of the page.  If using the printer wirelessly, you will also want to install the CANON IJ NETWORK TOOL from the SOFTWARE section.  Please install the items in the order listed. 

 

Once the drivers and software are installed, please restart your Mac.  If you still experience difficulty, we ask that you please contact us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

This did not solve my problem, but it did affirm that I had the right drivers installed and that those drivers were compatible with Mojave. I have been talking with Apple about this same problem, and it appears that there is a compatibility issue with some software users may have installed on their computer. In my case, they used the reset printer process to find and reinstall my printers and they worked fine. But ... if I have to restart my computer, they disappear again and I have to reinstall them by using the printer reset process all over again. It's a big pain! Apple is now aware of this problem and is working on it. I'm posting this in case other users are having a similar problem so they will know that it is a bug in the Mojave operating system.

Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM