Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot Install IJ Scan Utility/Driver for Pixma TS6420a


I've tried everything under the sun and downloaded the MP driver several times; I can get it to unzip but either it doesn't run or in any case it won't install the scanner software. I can print but not scan. Is there any other way to get it to scan? 



Hi judgegrover!


To have a better understanding of your issue, please let everyone know the operating system/version on your computer. Any other details you'd like to give, such as how long you've had the printer and how long you've had this issue, will only help the Community better understand your issue.


If this is a time-sensitive matter, please check out your other support options here:



Hi - I have Windows 10 (64 bit) and I just got the printer this week and have had this issue from day 1. I have tried restarting the computer, and disabling the fire wall. Those things didn't work. 

We recommend trying the wizard from this site:

It will walk you through the most current software installation process without having to do it piecemeal. 

I kept running into this error with the setup wizard: 



The Forums aren't intended for immediate assistance. If your question is of an urgent nature,click HERE to visit your My Canon Account to discover your personalized support options.

If you're outside of the USA, please click HERE to find your support options.