Showing results for 
Show  only  | Search instead for 
Did you mean: 

Call to Arms for the dreaded U052 Wrong Printhead Error


This is a "call to arms" for all of you Canon customers who have had this problem and have had their printers disabled because of it.  Please respond with the model of your printer and if you were able to fix it, what you did to fix it. 


We need to put pressure on Canon to respond this product defect.  It appears to be bad firmware that does not allow the user to override the problem and to continue to use the printer even in a degraded mode.  From my investigations the problem is NOT a printhead issue - no way one can be printing fine and then have this error alert without having changed the printhead or ink cartridges!


Canon, PLEASE take this issue seriously and provide a solution across the affected models.  If nothing else there should be a trade-in allowance for those printers that have been affected by this product defect.


I have had many Canon printers because they have superior functional specifications. I want to be able to continue using Canon products but only if I can have confidence that this product defect will not destroy my investment.


If Canon is unresponsive our next step should be to aggressively publisize this product defect on social media and on major product vendor outlet sites as negatives reviews.


Forum Users, please reply with your affected model number(s) and with details of any succdessful fix procedure.

1,478 REPLIES 1,478

Hi waleshd and steve2,


I hate to tell you but I don't think any amount of careful cleaning of the printhead will solve the problem. I suggest you look at the video posted by dacaes on 1/09/2016 showing the installation of a brand-new printhead, straight out of the package and it too soon exhibited the dreaded error. 


Early in this thread (which goes back many years!) someone suggests that it has to do with the firmware installed in the printer.


Of course, Canon denies that there is any problem -- hence the class action suit. Unfortunately, my problem didn't occur until it was to late to get in on the law suit.



I finally and sadly sent my 3-year-old printer to be recycled, and bought an HP printer. Now I'm wishing I had bought a more expensive HP printer -- but at least it works.


Good luck!




Well, actually, cleaning the printhead with alcohol DID solve my problem with the U052 printhead error message.  That is why I posted......

Yes, I used a qtip with alcohol and there was an ink buildup that I cleaned.  Once I cleaned that off and let it dry, I put it back in and it worked.  

You are lucky. You are not having the same problem that many others have. I am one of many who did what you did with no luck. many have done what you did and it worked for less than a week or not at all.


if the solution was so simple, Canon would not have lost a class action lawsuit. They have already agreed to compensate for the fault. I am one of many that will be receiving compensation for a class action lawsuit filed against Canon for the u052 error. The deadline for claims was december 7, 2015. You can Google "canon class action printer" for the latest.


Personally I believe the u052 error is purposely built into the firmware to force customers to buy a new printer. It back-fired in my case because I bought an HP.


Good luck

I had the exact same error message that everyone else complained about.  I certainly cant say that my exact same error message had the exact same source of the problem although the error message was exactly the same.  I hadnt read anywhere where other people tried alcohol to clean the head but I'm a techie and I just tried it.   I have had this Canon printer for at least 6 to 7 years and this is the first time I have had a problem with it.  But, cleaning the the printhead worked for me...cant say it will work or others.  However, after having this printer for 6 to 7 years, if it dies, I would just buy another one or buy a new part because things do wear out over time and I have gotten years of use out of it.   I suppose that I have had better luck than most but I do hope you have great luck with your HP.  🙂  

Thanks. I tried water and alcohol as recommended by Canon to no avail. Mine lasted almost 4 years. What bothers a lot of us is the way Canon ignored us, and that the printers worked perfectly a page before the error. Also scanner function shut down. Anyway 7 years is a good life and I would have been happy with that. I am not a complainer by nature but Canon's support is a joke.

thanks all


i will try the alchohol clean and then the shallow distilled water methods


- if the above do not work - i will get a Brother JP6240DW printer as replacement - currently $50 cask back in Australia

- sorry Canon but I have had 4 printers with you over 13 years (not a good average)


i will try the alchohol clean and then the shallow distilled water methods


- if the above do not work - i will get a Brother JP6240DW printer as replacement - currently $50 cask back in Australia

- sorry Canon but I have had 4 printers with you over 13 years (not a good average)




I tried cleaning the print head circuir board with alchohol


I tried soaking the print head in very shallow distilled water over-night (flushing the inky water many times prior to the over-night soak)


I was very careful and meticulous in both processes not to soak the circuit board




I will now be purchasing the Brother JP4620DW printer as previously mentioned. I have no choice, as purchasing a Canon is now too much of a risk with the U052 "print head is incorrect" error (which bascally shuts down the system)


Just an update:

I have my new Brother JP4620DW printer up and running and happy with it it looks so much tidier than my old Canon MG5350 and has a few more features (fax/A3/larger screen, near touch mobile transfer, auto copying of upto 20 different documents, etc). I will say however, that my old Canon had a slightly better print quality and a slight bit less clunky and quieter than the Brother is. But besides that the Brother is very good.

thanks all



I tried cleaning the printhead but it didn't work in my case. Still getting U052.


click here to view the press release