Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why does DPP4 crop my images when opening them?


When I open a CR3 image in DPP4 version, the image appears to have been cropped, that is ~5% of the top, bottom, LHS & RHS is missing with no way to retrieve it. Do I have an incorrect setting or have others had this problem?


Thanks John, I just took a couple of test shots and I think that you are correct, DPP shows what I see in the viewfinder, the CR3 out of the camera and Bridge appear to show additional pixels to what I see in the viewfinder.

View solution in original post



Just a guess, but could it be his native screen resolution and the scale (%) of the image he has set to display?

Edit.  Thanks for clarifying guys.  Disregard.  I thought he was describing a simple display related issue.



Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It


" I use Adobe Bridge to review my photos then use DPP4 to edit them. Neither the Adobe Bridge thumbnail nor the full size image are copped."


If this is true than something is happening when it goes to DPP4. I would suggest the first thing to try is to uninstall DPP4 and reinstall DPP4 making sure you have the most current version for your camera. 

I have a question, since you have Bridge you must have Photoshop so why use DPP4 at all? The editing ability of PS is so very much more greater than DPP4. I have PS and DPP4, too, but use DPP4 very infrequently.

EOS 1DX and 1D Mk IV and less lenses then before!


It looks like you have in-camera lens corrections applied:

Screenshot 2023-04-18 142757.jpg

Lightroom and Bridge do not read those parameters but DPP4 does. Run a test on a subject with and without in-camera corrections and see if that explains it.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

From exiftool, information about the crop.

  • [MakerNotes:Image] Sensor Width : 7128
  • [MakerNotes:Image] Sensor Height : 4732
  • [MakerNotes:Image] Sensor Left Border : 156
  • [MakerNotes:Image] Sensor Top Border : 84
  • [MakerNotes:Image] Sensor Right Border : 7115
  • [MakerNotes:Image] Sensor Bottom Border : 4723
  • [EXIF:Image] Exif Image Width : 6960
  • [EXIF:Image] Exif Image Height : 4640

IBIS will move the sensor changing those margins to get the advertised image size. Making several images in a row hand held might frame all the images the same while changing the margins. Other software might not read that information and crop it differently than does DPP.

For the "Why?" question, my guess is that it was based upon an engineering expectation that only that portion of the sensor chip would always be properly illuminated by the lens or maybe a requirement to produce an image with the advertised dimensions. For this particular lens, it is possible that more of the sensor chip is illuminated at wide angles than at telephoto.



Thanks John - I tried with and without the corrections and cannot see any difference in the cropping of the 2 images.


Maybe DPP crops it in an attempt to match what was in the viewfinder? With IBIS the sensor chip will move changing the margins.


Thanks John, I just took a couple of test shots and I think that you are correct, DPP shows what I see in the viewfinder, the CR3 out of the camera and Bridge appear to show additional pixels to what I see in the viewfinder.


Thank you all for your inputs - much appreciated!


I suspect this is related to my question asked here on CC and not answered.  I use DPP4 to convert CR3 to TIFF that will be focus stacked using Zerene stacker.  This can be 2 to over 200 images and ALL must be exactly the same size to the pixel.  Not selecting a resize option often produces a 1-2 pixel change part way through the group and this causes Zerene to reject the job.  When you do resize you are given a default setting for horizontal and vertical but this is not the same as the published image size as shown on the other DPP4 pages (6960x4640 for the R7, for example).  My question is why?  I see the possibility that it relates to IBIS or even some factor of lens correction in the software.  Specifically, should I select those defaults or change them to the 6960x4640 for best results?  When shooting focus brackets we must be sure that both ends of the series are fully on the frame (which end is a problem depends on whether you used the in camera focus bracketing routine or advanced the camera toward the subject using a slider like Miops or manually just by leaning toward the subject as you shoot). 

I have never used Zerene stacker. I use DPP or hugin to stack. I have EOS R5 and not R7. I hope some of this might help anyway.

I always see the same image size starting point in DPP unless:

  • I have done compositing in DPP
  • I have distortion correction enabled in the camera
  • I enable distortion correction in DPP
  • I have cropping enabled in the camera

I do not remember, but auto lighting optimizer or portrait lighting might make a difference.

exiftool -imagesize *.CR3

will report the size in the raw files.

exiftool -sensor*border *.CR3

will report some of the cropping hints that the camera puts into meta data.

I have not tried, but I expect that exiftool can also write other numbers to those values. This is complicated if the value exists in more than one place.