cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Update To Canon Connect App (version 3 - Released Nov 2022)

J-Gerard
Apprentice

HI - I have been working with the previous version of the Canon Camera Connect App with great success.  I had both my phone and my iPad connected to the EOS-R and then the EOS-R5 and the App would connect every time with no issues.

 

After the recent update to version 3 I can no longer connect my cameras to the app.  I get as far as connecting the bluetooth, which is promising because the app sees my camera and shows it as available when I open the App.  However, when I tap on "Import images" or "Shoot" on the main screen and the camera tries to connect to the iPad/iPhone using WiFi, I only get as far as the connection screen.  The connection is then immediately lost and I can not proceed any further with the app.  No remote shooting and no viewing the images on the camera.  

 

Troubleshooting steps - I have...  Turned on/off all the gear, deleted and reinstalled the app, Reset the WiFi & Bluetooth settings in the camera, Set up the iPhone App and Camera as a new device on a clean install of the app and I can not make it past the point where I connect with Bluetooth and then the WiFi connection starts and is immediately dropped. 

Anyone else having this issue?  What can I do to get the app up and running on my iPad?  Sharing images with my clients on the large iPad screen has been very popular with my clients and I would like to continue doing this.   

7 REPLIES 7

J-Gerard
Apprentice

I continued to troubleshoot the issue and wound up trying my iPhone again and I was able to successfully connect to the camera.  So that's progress.  

I returned to the iPad and in the WiFi settings I deleted the previous EOS camera connections.  After trying a few more times I was able to make a connection, view the images on the screen and trigger the shutter using the app. I'm hopeful that with a successful connection the camera and iPad will continue to connect successfully in the future.  I'll try again tomorrow.  

If the connection errors continue I'll need to find a different way to share my images with clients during a photo shoot.  I know I could tether to a laptop but the convenience of using the iPad trumps the tethering options.  

If the Canon Connect App doesn't work and you need to try something else look into Kuuvik Capture for iPad. In the App store. I don't use it myself but have heard good things from some other folks.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Greetings,

What you did is the recommended solution for re-establishing connections to new devices.  Reset the network settings in the camera, and forget the previous connections on the mobile device or iPAD.  Then perform set up again.  

~Rick
Bay Area - CA


~R5 C (1.0.2.1) ~RF Trinity, ~RF 100~400, +Canon Control Ring

~6D2 (v1.1.1) Retiring ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Thanks Rick, unfortunately the problem persists. I was able to connect last night but when I tried to connect this morning the same error occurred. ERR65 

the manual says it the issue is related to network interference. I moved around the house but I could only connect one more time. It seems like the app is no longer a viable option, at least for me. 

EOS R5 & iPad Pro with M1 chip both updated with the current software / firmware. 

This DOES NOT solve the problem. I've deleted the app and re-installed twice. The app forces connection though WiFi which is not an option for me. The older version used bluetooth and it was simple and successful. That option is either not available or so hidden as to be undiscoverable.

Canonprobs
Apprentice

Same!! I upgraded my iPhone so I had to reinstall everything and now I can’t connect via Bluetooth or Wi-Fi. It’s the worst! @canon help! I have the EOS M50, one of their most popular cameras, and it isn’t even listed as a camera registration option.

cannonsucks2000
Apprentice

This new app is useless. It requires WiFi to connect which is not an option for me.The earlier version used bluetooth to connect but evidently that is no longer possible. ARGH  I'm also very frustrated with the long series of steps necessary to make this comment.

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.