Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to download EOS Webcam Utility


I have been attempted to download the EOS Webcam Ulitity with no sucess. I have followed the steps to download it correctly and after I run the installation I restart my computer. When I look for the program it isn't in the windows menu. When I reopen the file folder and click on setup it gives me the option of repair or uninstall. I have tried to run it in repair but nothing happens. When I click the EOS Webcam Utility installer that is on the top of the list I get an error saying a previous version is installed and needs to be deleted, how ever I only attempted to download it that one time.


Can anyone help me with this issue



Welcome to the forum.




The utilkity starts when you connect the camera. It isn't a program you select and run by itself.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Thank you for the information. I will double check when I get home later but when plugged in the camera I didn't see it being picked up by the computer.

I think you also need to have a software like Zoom running. I tried it when it was a beta just to see what it did. Worked OK, but I haven't used it since, so I am going from memory. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

I apprently didnt write the software I was trying to use in my last Post. I am trying to get it to connect to OBS. When I attempted to connect the camera to the software I wasn't seeing it. However that could be due to OBS vs the camera/software. I will have to play around with it more later tonight.

Watched some more videos last night. Learned that I had to turn off Wi-Fi. OBS was able to read the camera.


Thank you for the help!