Showing results for 
Show  only  | Search instead for 
Did you mean: 

Shooting tethered - Canon 5D classic + Lightroom CC Classic + Mac OS Mojave


Hi all!


This must have been beaten to death but using the Google machine has not solved my problem this time so I am trying to get to the bottom of understanding things once and for all :). I own a combination from the title of this post and cannot get the darned thing to work, for the life of me!


What I have is the following:

  • Canon 5D original, decent working condition;
  • 2 MacBook Pro laptops: 1st 2015 (OSX MOjave), 2nd 2017 (OSX High Sierra 10.13.6);
  • downloaded the EOS utility on both Macbooks;
  • Lightroom CC Classic, legal, paid version, downloaded through the Adobe CC installer;

When I connect the camera through the white USB cable with the little round magnet attached to it, nothing happens.


What I tried:

  1. connecting the camera, turning it on, starting Lightroom;
  2. starting Lightroom, connecting the camera, turning it on;
  3. various other combinations, restarting everything, the computer, the camera;
  4. changing the "Communication mode" from Printer/PTP to PC;


The result:

Nothing works. The Lightroom camera controller "thing" shows no camera settings and the shutter button is disabled, WOS utility shows no camera attached.


Who is to blame here - Apple (none of the two OS versions supports the camera and Canon SDK), Canon (their SDK does not play nicely with these OS versions) or Adobe (Lightroom does not include the SDK to control the 5D camera)?


Has anybody had success in making a combo like mine work? Many thanks for any insight into this!






Either we find a way, or we make one.


John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic