cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

R7 Firmware v1.2.0 bug.

Pippers
Contributor

I have found a bug in the R7 firmware v1.2.0

With manual lenses that have no communication, the IBIS Image Stabilization is not working as expected. It is not using the correct "Focal Length" value that is inputed. IBIS is enabled, but it is ignoring the value that is set when turning the camera on. You can temporally fix this turning IS OFF, and then focusing with half press, then turning IS back ON. The R7 IBIS then behaves normally with the correct "Focal Length" value. When the camera is turned off, or goes to sleep it breaks again. This behaviour is best witnessed by using the 10x zoom through the viewfinder. You will see the effect of IBIS with IS ON as-is with incorrect value interpreted (Slight shake correction), with IS OFF (No shake correction), and finally with IS ON with correct value interpreted(Fantastic shake correction).

38 REPLIES 38

shadowsports
Legend
Legend

Greetings,

Someone else mentioned this about a month ago. It caused a heated debate. What was pointed out was the fact that the manual lenses in question were not Canon glass. Are the lenses in question Canon, or another brand?

If they aren't Canon, shouldn't the lens manufacturer be responsible for ensuring their lens works and properly communicates with the body, and not the other way around? I have enjoyed many non Canon lenses on other bodys on the past, but now utilize "Canon's system" (canon body and canon glass) as I have come to appreciate the benefits and results, they supply.

I would encourage you to submit product feedback.

You can do so from the support portal. Select [+]Feedback at the bottom of the page, then Product.

This will ensure your issue receives visibility and consideration.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

Hi,

if canon claims that their r7 body provides ibis, no matter what glass I put in front, the b o d y should provide ibis. It has nothing to do with the lens because there is no communication. 

Waddizzle
Legend
Legend

@Pipperswrote:

I have found a bug in the R7 firmware v1.2.0

With manual lenses that have no communication, the IBIS Image Stabilization is not working as expected. It is not using the correct "Focal Length" value that is inputed. IBIS is enabled, but it is ignoring the value that is set when turning the camera on. You can temporally fix this turning IS OFF, and then focusing with half press, then turning IS back ON. The R7 IBIS then behaves normally with the correct "Focal Length" value. When the camera is turned off, or goes to sleep it breaks again. This behaviour is best witnessed by using the 10x zoom through the viewfinder. You will see the effect of IBIS with IS ON as-is with incorrect value interpreted (Slight shake correction), with IS OFF (No shake correction), and finally with IS ON with correct value interpreted(Fantastic shake correction).



That is a lot to unpack.

First and foremost, the IBIS in the R Series bodies is not compatible with all Canon lenses. The camera Instruction manuals consistently refer to IBIS working with “certain lenses”, but without providing a list of them.

What manufacturer and model fully manual lens are you using? If your fully manual lens uses and EF mount, then what manufacturer and model lens mount adapter are you using?

I highlighted some of your text because you seemed to describe a sequence of steps that suggested that your manual only lens communicated with the camera body, telling the camera what focal length to use. Is that correct?

--------------------------------------------------------
"The right mouse button is your friend."

Pippers
Contributor

Manual lenses do not communicate with the R7. There are no communication pads on them. Such as old Canon FD lenses, or various third party manual lenses through an adapter. When there is no communication to the camera, it brings up the option to input the lens length so that IBIS can properly adjust itself. As stated in the manual:

"Image stabilization based on your specified lens focal length is possible by setting the focal length when using lenses that do not support lens communication."

Secondly, as I showed above, the IBIS does work as intended, however, you will need to turn off Image Stabilization, depress the shutter half way once, then turn it back on again manually, and the IBIS will function as expected using the inputed value.

The issue with the firmware is that when the R7 initially boots up, or comes out of sleep, it is not reading that value correctly, and enables IBIS at an arbitrary value that will not likely work with your legacy manual lenses. Turning IS off and on again after the fact shows that the correct routine is there, it's just not being called properly on first boot, or from sleep.

This is not a lens issue, it is a firmware issue.

If you do not wish to say what gear you are using so that I could attempt to reproduce your issue, then there is nothing more for me to say or do. Good Luck. Contact Canon.

--------------------------------------------------------
"The right mouse button is your friend."

Wow, I just joined these forums and I am amazed at the sloppy responses, some incorrect and some just arrogant. The brand of the lens is irrelevant. The camera provides image stabilisation for any lens based on its focal length, regardless of brand. The OP clearly stated what the manual says and it cannot be any clearer!

"Image stabilization based on your specified lens focal length is possible by setting the focal length when using lenses that do not support lens communication."

What part of that statement suggests brand has anything to do with the question being asked? The lens does not have to support communication and it states that.

Yeah, I was just posting here hoping a dev or support person would see this since the support area for my R7 leads me to this forum with the only other option of sending my R7 in for repairs. I wish Canon had a simple support email contact to send bug reports to, but I guess they want us posting here instead. 

 

I believe the people that kept asking for brand are wondering if the lenses I had problems with were the banned lenses that have electronic communications and auto-focus, which they do not, because I stated it is only happening with fully manual "dumb" lenses that have no communications. Canon still allows those lenses to be made for the RF mount, as you can find many larger name brands making them, and they've not been asked to stop yet. 

The Lensbaby, 7Artisan, TTArtisan, Adapted Canon FD, Adapted Manual Lenses (Leica etc) etc all have this issue. It's nothing a lens manufacturer can do as there are no electronics. It's purely IBIS code within the firmware that is fixable by turning it off, half press to meter, turning it back on again. 

 

For those of us who like these fully manual lenses, it is a pretty large issue as IBIS is one of the main selling points of this camera. 

I have seen something similar when the EOS R5 wakes from sleep. The IBIS forgets the focal length. The only adapted lens with no electronics that I use is 50mm, so that lens works, but on some other lenses I saw the problem. On the EOS R5, I got in the habit of turning the camera off and back on again if it had gone to sleep. I think that this may have been fixed for the EOS R5 with firmware 1.6.

---
https://www.rsok.com/~jrm/

Thank you. I did notice when I first went into the Focal Length option, it was preset with 50mm. I am wondering if that is what the setting is at boot/coming out of sleep so that it works for you.

Avatar
click here to view the press release
Announcements