Showing results for 
Show  only  | Search instead for 
Did you mean: 

Powershot driver compatibility with Win7_64 bit?


Hi, I have two older Powershots the A560 and the later A650 IS which I really like. I also have a Canon Canoscan USB scanner and it's drivers installed. Since migrating to 64 bit windows a while ago I've had problems with the powershot drivers installing. After a reboot I see the cammer name listed in the hardware with an exclamation error. If I delete the driver and re-connect the camera, the driver reinstalls and I can access the shot memory card. After the next reboot the driver again shows an error.  going around in circles I might have tried removing the Canoscan scanner software and got the powershot drivers working without errors, but can't say for definite? I think the Powershot drivers work with Windows UTP which is always being updated. Android and other newer USB devices connect and self install drivers without erros.


The Canon USB drivers are installed from the camera firmware and as far as I know there have been no updates. Has anybody else had problems connecting their older Powershot cameras to 64 bit Windows? I can always remove the cards or keep deleting and re-installing the driver, butI would be interested in finding a solution.





I solved this nasty problem:


Powershots install their (oldish) driver when USB connects. Unlike my Canoscanner which has drivers shipped on CD. Camera USBs are 'discovered' as portable devices using Windoze MTP. In my case, My Win7_64 was not running its event logging which shouldn't be a big deal. If I uninstalled the Powershot driver and re-installed it, everything worked until the next reboot. Driver manager then reported 'driver failed to initialize' error.


I tried to run Event Viewer for further diagnosis but got an MMC snap in event viewer error 37 and no logs. Then I was seeing error 4201 (Event service not logging) even though the services were running? A Windoze file system check gave no errors?


After further investigation I found the Windoze system folder holding the error logs did not have system level permission. When the Powershot driver tried to initialize at reboot, I think it produced a non-critical error, but this could not be written to the log and gave the error 'Driver cannot be initialized'. Now I have Event Viewer working I can look into this further, but I suspect it could be linked to early versions of .Net Framework required for older programs?


Both my Powershot cameras now connect USB without persistent driver errors.