cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MAC- EOS Solution Disk 29.0A Installer Doesn't Work

bsorgi
Apprentice

Hi All- 

 

I am running Mac OS X 10.9 and just downloaded the EOS Solution Disk 29.0A image from Canons website. 

The image verifies and extracts properly. When I launch the ksd290A_installer it appears to extracts files but then nothing else happens. No errors, no installer, nothing else happens, nothing..

 

Please advise? 

13 REPLIES 13

jdlambert
Apprentice

I'm having the exact same problem.  It must be something with permissions or the user account because I tried installing under a different account and it installed, it just won't install under my normal account.

Mykolas
Authority

Hi bsorgi!

 

Thanks for the post.

 

I agree that the permissions may be to blame here.  try using the disk utility to first verify, then repair the disk permissions.  After they are repaired, you should be able to run the installer successfully.

 

This didn't answer your question? Find more help at Contact Us.  If this is a time sensitive-matter, additional support options are available.

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Mike, bsorg

I had verified and repaired the disk permissions but that didn't resolve my issue.  It is still something with the user account, I just don't know what it is.

 

After installing the EOS Solution Disk 29.0A Installer on to a different account (with Admin rights), and logged back into my normal user account the software was all available for my use.  This may be a work around for bsorg also.  I would like to figure out why this didn't install under my normal user account.  I wonder if it has something to do with upgrading from 10.6.x to 10.9.x, perhaps that is where the corruption took place.

 

Good Luck bsorg!!

Thanks Mike for your response!!

jdlambert

it isn't with upgrading 10.6.8 to 10.9.x.

 

I instaled the EOS Solution Disk 28.2A when I was under 10.6.8. I did it with an Admin rights account, it was not possible to do it in my normal one. I've recently upgraded to 10.9. I am wondering why the apps have not yet auto updated. Does not work properly the Auto Updater Service? Must I download and run the EOS Solution Disk 29.0A.

 

Thanks.

Hi Pinholder,

 

The updater wouldn't work for me either, I ended up downloading the EOS Solution Disk 29.0A manully and did the install under a admin account.  

 

Good Luck

 

I am having the same problem. I verify the disk and it says its okay. What else can I try?

I'm having the Same problem with the EOS Digital Solutions ver 30.2 on my macbook running OSX 10.10.4 .  The Disc installer will not load nor will the one downloaded from canon.

Help !!! 

Just ran across this problem, myself, but with Solution Disk 29.1A under OS X 10.10.5. As others have reported, it reports it's extracting files then nothing happens.

 

I tried running the installer manually via the command line, and got an interesting clue to the problem. After extracting files, it reports an error and terminates. Here's the messages reported in the shell (with the temp paths slightly altered, just to be on the safe side):

 

CResourceBundleStringTable::GetStringForKey: /Volumes/EOS Solution Disk 29.1A/ksd291a_installer.app/Contents/Resources/UILang/en/OFIStringTable.def: OFIStringTable.def: 'OFIString_FILE_EXTRACT'='Extracting Files...'
objc[23432]: Class CmdUtil is implemented in both /var/folders/blah/blah/blah/CanonOFI_TEMP/Data/Software/Install/UniversalInstaller.app/Contents/MacOS/UniversalInstaller and /var/folders/blah/blah/blah/CanonOFI_TEMP/Data/Software/Install/UniversalInstaller.app/Contents/Frameworks/UIx.framework/UIx. One of the two will be used. Which one is undefined.

 

So this appears to be a bug in the installer when run under OS X 10.10, with the class CmdUtil defined in two places and causing a conflict. I've tried running the same installer under a VM running 10.9 on the same machine and it starts successfully (not that it helps).

 

Cheers,

Gordon

 

Trying to instal 29.1A downloaded today and I get exactly the same - the files extract but nothing happens. Permissions have been checked and no error messages appear.

Avatar
click here to view the press release
Announcements