cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How do you connect two canon DSLRs to EOS Utility so you can have multiple cameras in Streamlabs

mbro620
Apprentice

I am having issues connecting multiple cameras into streamlabs using EOS Utility. Both cameras are connected to my PC using a USB connection. I can get them both to come up in EOS utility and streamlabs but when I connect the second camera I lose connectivity to the first. This is very frustrating as I have even upgraded my subscription in hopes this will work.

Thanks,
Mike

4 REPLIES 4

shadowsports
Legend
Legend

Greetings,

I assume you are referring to the EOS WebCam Utility Pro, and not the EOS Utility?

Which cameras are you connecting?

Do both streams appear in the WebCam Utility Pro?   Is the issue just with StreamLabs?

Have you reviewed the Quick Start Guide?

To connect multiple cameras, you must be running v2.1 and have a Pro Subscription.  The EOS Utility should not be running.  Both the program and the Camera Monitor in the System Tray should be closed.   Please verify the WebCam Software is correctly registered and linked to your subscription.  This is covered in the guide above.     

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hello,

Yes, I am using the EOS Webcam Utility Pro.

I have a 5D Mark IV and an EOS 80D. 

When I try to add a second camera in WebCam Utility Pro it's giving me an error.

I will try the quick guide again and I did end up upgrading my subscription so I could add a second camera.

I will circle back. Thank you so much for your help!

Best,

Mike

shadowsports
Legend
Legend

Mike,

Don't feel like I've helped yet...  but am happy to continue.  🙂

Please share the error with us when you can.  We'll do our best to help.  

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Rick,

I was hoping the Quick Start Guide would have some good info in it. Whenever I have multiple cameras connected to my computer it seems like it is competing for the video. If I turn off my 5D I am able to setup my 80D. Once I connect my 5D the 80D video freezes and I am unable to add the 5D camera to a scene.

If I just connect my 5D it works fine. The minute I try to add the 80D camera to a second scene it freezes the video on the 5D and I can't add my 80D to a new scene. Seems like I can only have one camera connected a time.

Is this making sense?

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements