Showing results for 
Show  only  | Search instead for 
Did you mean: 

HELP! Canon M50 as webcam on M1 Mac? (Utility not reading camera)


Hi everyone. I'm about to punch a hole into something if I can't figure this out. I'd appreciate any help!

A couple years back I had a great setup using my Canon M50 in conjunction with Zoom for super high-quality calls. I've since moved a couple times and I've been trying to set it up again in our new place but things appear to have changed. My hardware setup hasn't changed at all— but Mac OS has updated, as well as the EOS Webcam utility. 

• MacBook Air M1, 2020 with Ventura 13.4
• Canon M50 Camera
• Latest version of EOS Webcam Utility Pro

I've watched several videos on how to fix this but none of them have worked. I've just about given up but I since I know it was possible before with all the same hardware I can't imagine why it would be impossible now. I've got to be missing something. I've even tried uninstalling the current version and installing the original, as suggested by one of the videos. It still didn't work. The EOS Utility shows up in Zoom and other software, and my camera is on and connected via USB-C, yet it's like it's not there at all. 

If this is truly just an issue of the software no longer being compatible... and Canon is simply not going to fix it, I'd love suggestions on how to alter my setup. I'm learning the ropes to building a YouTube channel and its annoying and demotivating to keep moving my SD card back and forth between the camera and my laptop. 



Is the camera recognized by non-Canon software like Image Capture?

If not, check that the USB port is authorized in the security section.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic
Enter for a chance to win