cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error during remote shooting say I need EOS Utility but I have it

Beekeeperjen
Apprentice

I have installed the Digital Photo and Webcam Remote Shoot and there is an additional download that appears to be an EOS utility but I keep getting an error when I try to use remote shooting that I need to download the compatible Eos utility. I downloaded both from canon website for my Rebel T3 on Windows 11 and Mac big sur 11 and I get the same error code on both devices. Macs error says need to download eos utility 2. I have spent about 4 hours on this starting to get flash backs from the 90’s with my DOS based programs. Can anyone help me with this I have scoured the Internet but to no prevail. Thanks

1 REPLY 1

jrhoffman75
Legend
Legend

Go to the support page for the Canon 1D X Mark III:

Canon Support for EOS-1D X Mark III | Canon U.S.A., Inc.

Set Big Sur OS version.

Scroll down several pages till you see EOS Utility 3.13.20. Download and install that software. It will install EOSU3 and EOSU2.

Screenshot 2024-01-26 081629.jpg

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic
Announcements