Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS utility outdated for Rebel xs seeking a "work around"


I have a Canon Rebel xs ( bought new in 2017) mounted overhead to capture jpegs remotely on my Mac OSMonterey 12.6.6. After not using the set up for 8 months, I opened my laptop to find the icons ghosted out with alerts that those features needed updating. Not finding downloads available, Canon customer service informed me that my camera is "out of service life", and that they no longer provide updates. I want to avoid buying a new camera - I like this one and it is like new! Does anyone know a good way to capture live high res. jpegs in sequence remotely with my Rebel xs so that I can continue to make stop motion animations, without using the EOS which I no longer have?


Not applicable

What software are you using and how are you connecting your camera to your computer? Have you changed anything on your computer to cause your software to stop working?

Hello 5DIV, 

Thanks for your question.

I believe that I updated my Mac OS since I used my Canon EOS.

I now have Monterey 12.6.6.  Seeing that I had alerts to update my EOS I went through an elaborate set of moves to download an update and even tried downloading updates that were not specified for my camera. In the process ( at the advice of Canon customer service) I threw out the versions on the EOS utility that had been working but I could no longer get to open before downloading new one. I downloaded Utility 3 which would not connect to my camera. I got a notice that I needed to download " EOS Utility 2". Could not find it. I was excited when I got a notice that EOS update 3.17.1 ( 2021) was "available to download".

Once downloaded, I tried to open it and AGAIN got an alert that told me to download "EOS Utility 2". I cannot find that utility available. I think customer service was telling me this is what Canon no longer makes available (?) 

I'm thinking that I might need to go back to using and earlier mac Os. I'm not sure how to do that but Im willing since this laptop is devoted to capturing jpegs for making animation and I don't need to be able to us other Adobe apps that need to be current. Sorry to ramble -stressed out trying to solve this.

Any ideas?

Not applicable

By any chance, do you have the CD disc that came with the camera? If so, it should have the EOS Utility on it. If you aren't able to find EOS Utility 2 for your MAC, do you have access to an old Windows computer? There is EOS Utility 2 for Windows available on the Canon support site. Here is a link for a EOS T2i 

Hello 5DIV Yes, I have the original CD. Im afraid that once i load it, it will be incompatible with my new MacOS Monterey. Thank you for your suggestions



Also, to answer your question; I am connecting to my camera with a USB cord. Ive checked all cords are working. Thanks




Earlier versions of the EOS Utility include both EU2 and EU3.  Your camera requires EU2.  When the software is launched, it should detect your camera and start the version of the Utility needed for your particular camera. This doesn't always happen, especially with older body's.  

If I recall v3.16.x contains both EU2 and EU2.  Later versions, possibly v3.17.x also contained EU2 as well.  The issue that you might also run in to is OS compatibility.  I would try installing v3.16.x.  Its not camera specific, so you can use the installer on another body's support page to get the installer if needed.  

After its installed, open the Canon folder in finder and look for EU2.  This can be launched manually.  This method may or may not work. 

Other options for transferring photos.

Image capture, a card reader or simply opening the camera as a mass storage device when connected and dragging the photos on your MAC instead.  

This table can also be used as a helpful reference:

Mac OSX Monterey v12 | Canon U.S.A., Inc.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thank you Shadowsports - Im looking into your leads, and will respond asap. Much appreciated!



I suggest that you either find an older Windows computer.  I have no idea how many older Mac computers are out there still running an older OS?

"The right mouse button is your friend."

I am not friendly with windows - Im a Mac enthusiast. Thank you anyway, Waddizzle