Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam will not install EWCService.exe failed to start. Verify.....sufficient privileges


Windows 10, fully updated as of 2/10/23.  

I borrowed some text from another thread but it describes the problem in detail.. 

"It flat out refuses to install. I go through all the install process, it unpacks, goes through install progress bar comes close to complete, it hangs for several minutes and then pops up with

EOS Webcam Utility

! Service EWCService' (EWCService.EXE) failed to start. Verify

That you have sufficient privileges to start system services.


Try retry all day long and it just repeats only option is to cancel"  .......which uninstalls the package.

I am administrator and right clicking and running the install as an administrator does nothing.


I have rebooted, updated the machine to the latest version available and installed GPEDIT.MSC and set privileges in it according to a web article.  Still does this and it will not install. 

The log that is generated is useless.  The developer created an exception routine but didn't put anything in the log to say why the exception occurred.   



I’m just the messenger.  I apologize for explaining why it will never work with an upgraded Win10 OS from Windows 7, 8, or 8.1.

"The right mouse button is your friend."


I have been having the same problem. I have been able to download other stuff. I specifically bought my camera for using this feature. I made sure my brand new computer has all the specks it asks for. I am getting really frustrated and trying to find different off brand program to download that will work instead. 

There is some nuance that the install process is missing.  I actually ran the install until the error message popped up and then went into services and EWCService was actually installed, and started, (with Automatic setting) so this is a false error message.  Something else is going on.  I confirmed this by running the EWC Utility, since the shortcut remains until you cancel the install, and was able to see it as a camera option in Windows camera.  However it would not feed video....I suspect the install is not entirely done.   I powered down the machine using the long press on the power button (to exit without the uninstall process running)..  When I restarted the laptop the service was still installed. The EWC still showed as a camera option but it would not feed video....again it was an incomplete install.  I am at a loss as to get it working.  It should.  I am still pondering but may not have any more avenues to pursue.

BTW, thanks for posting.  This confirms to me that it isn't an "old" machine issue since my laptop also meets the minimums as stated by Canon.  Can I ask what machine and operating system you are having problems  on? And, does your new machine have a built in camera?


I have the same error. I have an old motherboard with a q9550 processor, 1050ti graphics card and 8gb of ram. Could this be a problem? Or is the problem because I'm from Russia?))) I hope it's not so 🙂 Tomorrow I'll try to install the software on another computer, I hope the situation will change. I wish you all the best! 🙂


Smh this is crazy I been trying since 12 noon and still nothing, brand new laptop :.. did u figure it out ? And ifso plz let me know …. Windows 11

No luck so far.  Haven't done much more.  One of my posts in this thread explains that I believe the error is a bogus message since I could see that the EWCservice.exe had actually installed and started.  Too much else to do rather than chasing this....


I appreciate your diligence in reporting and following up on this problem. I've encountered the same error—though, in my case, the error message was a correct report; i.e., the service had not, in fact, started successfully. Since it sounds like the error message was incorrect report for you, I've created a new thread for my scenario. As they're so closely related, however, I wanted to make you (and anyone else with this error) aware of that thread as well. In the meanwhile, I hope you've had more luck than me in getting this resolved.

Try the following.  

When the error dialog pops up...

Windows+R key

Enter "services.msc" in the run dialog, press ok


Scroll to service EWCService.  Right-click on it and select properties.  Change start up type to disabled.  Now select stop service.  Once the service stops, press the re-try button on the error dialog.  The install should complete.  Change the service start back to Automatic, save.  Restart the machine and test. 

I have not tested this myself.

**Edit, there is a difference between the v1 and v2.0 versions of the software.  (Device driver vs. application) v1 did not work when the EOS Utility was active.  I'd exit this app from the system tray (temporarily) while I tested v2.0.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Thanks for the suggestion.  It will be later today but I will give it a shot.

Tried this and still get the same error.   So, I tried to manually start the service and no matter what state (automatic, manual, automatic (with delayed start) I could not manually start it.  Got a 1053 error, "The service did not respond to the start or control request in a timely fashion".  So based on Googling I ran an sfc /scannow but no errors were found.  The next step will be to edit the timeout in the Registry and see if it is set properly.  At a loss beyond that.  I see that a couple of others are now reporting the same problem with much newer machines.