cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility won't launch on Windows 10, OK on Mac

Mike8
Enthusiast

I'm using a Canon Rebel T6s DSLR camera with a Motic BA 300 trinocular microscope.  I'm attempting to remotely control the camera on my Windows 10 computer with lastest version of the Canon Utility, i.e., EU3.  I successfully installed the utility,  but it will not open with Windows 10.  Similarly,  I installed it on my MacBookPro and had no problem at all.  I've tried just about everything to get the utility to work with Windows 10 including compeltely erasing the computer and starting over.  I'm considering ridding my computer of Windows 10 and perhaps iinstalling an earlier version,  one more friendly toward Canon software.  Does anyone have any suggestions?

4 REPLIES 4

Mike8
Enthusiast

I forgot to ask if anyone knows of an earlier version of the Canon Utility,  not EU3,  that will work with Windows 10,  and where to go to download it.

Waddizzle
Legend
Legend

When you connect the camera to your PC, does Windows even see it?  Can you see the camera in Windows Explorer?

 

BTW, on some Windows PCs the EOS Utility needs a jump.  Try going into Programs folder on the C: Drive, and manually starting the EOSUtility3 executable file.

--------------------------------------------------------
"The right mouse button is your friend."

Mike8
Enthusiast

As stated in my previous post,  I cannot get EU3 to work with Windows 10.  Does anyone know of an earlier version of the Canon Utility that WILL WORK with Windows 10,  and where to go to download it?

Greetings,

All previous versions of EU2 and 3 have worked in my environment. Windows 10 Builds 1709, 1803, 1809, 1903 and currently 1909.

 

EOS Utility versions v3.12.10, also 3.12.0, 3.11.0, 3.10.30, etc..  (and many more)

 

You can download the EOS Utility (current and previous versions) from your Camera's Support Page.

 

Enter your camera's model here:

 

https://www.usa.canon.com/internet/portal/us/home/support?tab=drivers

 

Then Software and Driver's > Select your OS. 

 

You will see downloads for the current version, as well as earlier ones.

 

Regarding your issue.  There could be several reasons why any software might not run in your unique environment.  It might be your hardware or something that exists in your OS.  Other software, missing drivers, updates, etc.

 

Unfortunately, "Can't open" isn't a good  (complete) problem description.  It doesn't tell us what you did, or what happened when you did it.  We are not there to see what's happening. 

 

Can you tell us more:

Windows 10, running on?

Build number?

Installed version of EOS Utility is?

Steps performed?

Error Messages displayed?  

 

We need something meaningful so we can try to help.  The more information you provide, about your environment, hardware, software, etc, the easier it might be for us to help identify the issue.  I cannot confirm if an earlier or later version will work, but you can definitely give it a try.  Please understand however, you will also need to tell us something more than "I am running windows 10". 

 

Thanks,

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Avatar
click here to view the gallery
Announcements