Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility crashing mid-transfer via USB


Sup y'all.


So, I have an EOS 1300D (Rebel T6..? I think) that has been serving me for several years now and that's nice.


I have always used EOS Utility (via USB cable provided with the camera) because frankly - it does the job well and it organizes everything which is awesome.


Now, for some reason I had 500+ photos on the card that aren't on the computer (dating back to June-ish), and today, for the first time in a while, I shot a couple dozen of somewhat interesting photos and wanted to edit them on my PC.


However, I ran into a weird issue today where it would transfer a photo, and then crash (no error codes at all)/disconnect from the camera. Windows still says it's connected and I can manually find the files on the camera/card.


Okay, no big deal I guess, I'll just copy/paste the 300 something photos manually while leaving just a few for the program to transfer. Again the same issue.


Updated the software, completely removed it (not just uninstall but removed every trace of any Canon software) - the issue happens again. Tried different USB slots on the motherboard - that's right, it happens again.


Camera firmware is updated to the latest revision (from October last year).


I guess the only thing I haven't tried is using a different cable but I don't have one (yet).


OS: WIndows 10 Version 21H1


Appreciate the help,


Homer Thompson,

Terror lake



Product Expert
Product Expert

Hi there,


I wonder if a corrupted file might have something to do with this. If you have a few extra minutes I might try transferring those files in sets, maybe 100 at a time, to see if the program crashes in a specific range, and then if possible checking that set in chunks of 20 or so to start narrowing it down. If you can find the offending file you can skip it and transfer the remainder. If that works (assuming a corrupted file/s was the cause of the issue) you can then try to run a data recovery program to try and recover the file.


Whether that solves it or not, it would also be a good idea to see if the issue happens with another new set of images, ideally on a different SD card. That would let us know if the file itself was a problem or if the SD card or camera may have caused the issue, but based on what you described I suspect a corrupted file is the culprit.



Thanks for the reply.


I took about 40 new photos today and manually transferred the previous ones - I don't think any of the files were corrupted as they work fine in Lightroom and other photo editing/viewing programs.


The problem still persists today even on the brand new images, which makes me think the SD card could be the culprit, I'll try a different one and see if it works.


Edit: Tried a different SD card but same adapter - same issue. I can't find a second adapter right now so I'll update after the weekend.