cancel
Showing results for 
Search instead for 
Did you mean: 

Webcam Utility, completely freezing a Mac for 10 seconds

achempion
New Contributor

Hey,

 

Currently I'm using my m50 as a wecam. The issue I have is when I open a Chrome for a Google Meet meeting and connect my camera, after 20 seconds Chrome starts consuming all the CPU cores for 10 seconds and all the interface basically freezes, sometime I have to reconnect to the meeting because sound stops working.

 

I'm using MacBook Pro, 2020 with i5 processor and 16GB.

 

After this initial "warm-up", all works fine. It happens only when I use m50 as a webcam.

 

I've tried using firefox and OBS with virtual webcam plugin but the issue persists across these setups as well.

I also tried re-installing the webcam utility.

 

One thing I've noticed, that it happens only on 2nd or 3rd meeting and next after the restart. Basically, if I want to use my canon m50 as a webcam, I have to restart my computer before each meeting to not have freezing issues.

 

I mostly use Google Meet and haven't had a chance to properly test this issue with Zoom.

 

I've tried researching a camllink setup, but you have to turn autofocus off in order to get clean hdmi output and plug camera with micro-usb as well to avoid it powering off after 30 minutes.

5 REPLIES 5

Waddizzle
VIP

Here is a link to the EOS Webcm Utility download page.

 

https://www.usa.canon.com/internet/portal/us/home/support/self-help-center/eos-webcam-utility/ 

 

Google Meet does not appear to be listed as being aupported.  I think OBS is supported, but I question whether or not using a Firefox plug-in for OBS is also supported.

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."

Thank you for the reply, on a page you've linked they mention Hangouts and Hangouts Meet.

I've tried using OBS with virual webcam plugin but the issue still exists when I connect to the Meet meeting.

Waddizzle
VIP
So the problems start when you try to connect OBS with “Hangouts”? But, your camera connects to OBS just fine?
------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."

Stephen
Moderator
Moderator

Hi achempion!

 

Just so everyone is on the same page, which version of macOS are you currently using?

I'm using Big Sur 11.4.

 

It happens every time I connect to Google Meet meeting (on 2-4th meeting after the restart), especially if there is more than one participant. It doesn't matter with OBS or directly.