cancel
Showing results for 
Search instead for 
Did you mean: 

EOS Utility Works, but Win10 doesn’t see it?

SoulmanPZ
New Contributor

Hello there,

 

I'm a brand new Canon 90D customer and I'm in love with this camera! I run it on a fairly no-frills config, a Dell XPS 15 laptop, with Windows 10/64. All drivers are up to date, and system updates run automatically.

 

For some reason my EOS utility actually connects to the 90D, I can even start remote shooting etc. just fine, but for some reason Windows isn't recognizing EOS as one of the drop down options in various video conferencing software (MS Teams, Skype etc.), I even installed OBS, and that couldn't find my camera either.

 

What's really strange is that the 90D is listed under devices and printers, but it can't be set as default, which is probably a driver limitation.

 

Anyways, I tried uninstalling, unplugging, different cables and USB ports/hubs to no avail, any advice would be truly appreciated.

 

Thanks in advance,

Peter

2 REPLIES 2

Mark35mmF2
Product Expert
Product Expert

 Hi there,

 

Based on what you're describing, I recommend making sure the EOS Webcam Utility is installed, as the EOS Utility and EOS Webcam utility are different programs. You can get the proper version of the EOS Webca Utility here: https://www.usa.canon.com/internet/portal/us/home/support/self-help-center/eos-webcam-utility/

OMG, Mark, you saved my life!! This isn't embarrassing at all, I apparently developed some IT tunnel vision and stopped differentiating between the two programs, while one is really a driver, duh 🙄 

 

You are my hero Mark, it's working as advertised, I'll be sure to incorporate that in my YouTube vids!! Feel free to mark this as solved, but maybe keep it, so another user might benefit from my error.

 

Truly,

Peter