Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS M50 not being recognized by EOS Utility


I've got the camera in pairing mode, I've confirmed that it's connected to my wireless network, but the EOS Pairing Software simply cannot find it.  I was able to pair it before but it would disconnect after ~30 seconds and it would take 2 or 3 tries for the software to recognize the camera was trying to connect.  After a lot of searching I saw a suggestion that maybe updating Windows 10 might help.  After the update was complete, EOS Utility wouldn't even launch so I uninstalled and reinstalled it.  The software would launch but it wouldn't pair, so I deleted the information on the camera so I could try re-pairing with the fresh install.


And that's where I am, several hours later and no closer to pairing the software.


I've tried connecting via USB as well (yes, I turned off the camera's wifi first) and my computer didn't even recognize that anything was plugged in.  I tried 3 different cables, and I've ordered a new cable just in case.  The camera also didn't seem to recognize the USB cable was plugged in, either.  Sometimes it would disable button presses (it would say "busy" when I hit a button like menu) but sometimes it behaved completely normally.


I can connect via bluetooh on my phone.


Picture:  Confirmation the phone is connected to the same wifi network and that the EOS utility sees exactly zero cameras.





What I gathered:


MAC: 18:48:CA:03:0D:73 has IP (M50)

and and are a computer and a phone according to Nirsoft.


And you appear to be able to PING the Camera at .21 successfully which might rule out a firewall or 3rd party AV issue.  This would lead me to believe there is a problem with the utility software or installation, but the fact that you don't get any type of mass storage device detected when connecting the camera via USB isn't promising.  Windows does not need any Canon Software to see your camera's storage when connected via USB.     


Start with this.  Connect the camera to another machine via USB.  Does this work?  If it does, there is an issue with the computer (software environment or hardware).  If not, the camera or the cable being used.   


I also see you are running Windows 10 20H2.  It seems to have caused other issues for you since you mentioned that the EOS Utility wouldn't run after the update until an uninstall / reinstall was performed.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

First, USB.  I was able to cobble together enough adaptors and I tested all the USB-A to Micro-USB cables I could find...  all bad.  They can transmit power, but data connections are not recognized.  I ordered new ones that came in just now and the camera works as expected over USB with no surprises or hiccups.  So that's good.  It doesn't even do the 20-30 seconds and then disconnect like wireless did when I could get it to connect at all.


I tried wireless on my wife's Win10 computer.  I'm not sure exactly which update she's on and I can't check right now, but it's whatever update was the most recently autoapplied.


Exact same wireless problem.  EOS Utility simply does not recognize the camera on the network.