cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

DPP4 Universal Installer and Run As Admin not working

Pepi
Apprentice

Hi,

I tried to ask this from support as well, but without success. The basic security rule for using the personal computers is to not run your workstation with account having local administrative credentials in every day surfing. So when ever I need to admin privileges I'm using "runas administrator" process on Windows 10 64bit.

By some unknown reasons when trying to install Digital Photo Professional software (earlier 4.17.20 version) version 4.18.10 version, and performing the dppw4.18.10-installer.exe using the RunAs administrator:

 

Pepi_1-1709072050468.png

It will ask account and password from me on the next request. Then it start extracting the package to the temp folder. But then, it doesn't matter how much I'm dancing, that fails when the actual installation should be starting to the error:

Pepi_2-1709072111128.png

"Installation program of Digital Photo Professional 4 requires administrator privileges."

I already wondering if I should try to do the installation from the temp folder, one by one. Instead of that I'm wishing to see that there could be developer who is managing the UniversalInstaller.exe and patching it to check for the administrative privileges. I believe it does that a bit incorrect way.

On the logs I can see one error there, but that says not so much:

20240227234451:INSTALL:UIx INFORMATION ResultPlugIn=UIxMarketPlugin,RegionGetLanguageCodeAt,en
20240227234451:INSTALL:UIx INFORMATION CallPlugIn=UIxMarketPlugin,CheckAvailable
20240227234451:INSTALL:UIx INFORMATION ResultPlugIn=UIxMarketPlugin,CheckAvailable,0
20240227234451:INSTALL:UIx INFORMATION Error=UIx is not supported.
20240227234451:INSTALL:UIx INFORMATION CallPlugIn=UIxMarketPlugin,GetProductName
20240227234451:INSTALL:UIx INFORMATION ResultPlugIn=UIxMarketPlugin,GetProductName,Digital Photo Professional 4
20240227234834:INSTALL:UIx INFORMATION CallPlugIn=UIxMarketPlugin,MarketRelease,0x0121b220
20240227234834:INSTALL:UIx INFORMATION ResultPlugIn=UIxMarketPlugin,MarketRelease,0

 

4 REPLIES 4

Danny
Moderator
Moderator

Thanks for joining the conversation, Pepi!

So that the Community can help you better, we need to know exactly which version of Windows is running on your computer. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

Thanks Danny,

The Windows I'm using is Win10 64bit (19045.4046).

No this is not that sensitive, I have survived with alternative tools, but would like to try with Canon own tools as well.

shadowsports
Legend
Legend

Greetings,

If your existing account has limited permissions, you must have another account with admin.  Log in as that user and install DPP4.  Then log back in as your current user with limited access.

I'm not sure how much time you want to spend trying to figure out what in your environment is keeping the software from installing.  Profile or file system corruption, issue with installer, 3rd party AV, etc.    

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hi Rick,

Thank you for your reply. Yes, the regular account what I'm using for my daily work is limited. But as I wrote, if I'm using "run as Administrator", there cannot be more powerfully account on Windows machines than that (yes system account could be). And still the installation is failing. But as I do that with "run as" that could be the reason, as most of the people run with local admin credentials and not even noticed challenges like this.

The account could be corrupted, and if it is so, I definitely like to find that. But by some reasons DPP seems to be only software which does not work with that account, but all other software does. So there could be some theoretical possibilities that software could be broken? If there is a problem on software, perhaps Canon like to get that fixed as well? 🙂

But perhaps the error on the log could bring the issue a bit more closer.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements