cancel
Showing results for 
Search instead for 
Did you mean: 

DPP 4.13 keeps freezing

troshalom
Contributor

First time I've used DPP since I updated it to 4.13. I opened it and just looked around, clicked bookmarks a folder and it is not responding. End Task, and after relaunching the application several times it just freezes. This time. I opened it, navigated to a folder and started watching the video on the new features and without doing anything in DPP it freezes. After several minutes it unfreezes then a couple minutes later it freezes again and stops responding.

 

I did not have these issues with 4.12 - I am running Windows 10 v2004

 

How do I fix this?

9 REPLIES 9

shadowsports
Elite

Greetings,

Can you provide your complete system specs for us please.

 

Desktop / Laptop

System / model

CPU type (Intel / AMD)

~Rick
Bay Area - CA
~R5C (1.0.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra
~ImageClass MF644Cdw ~Pixel6 
~6D2 (v1.1.1) retiring

Hi Shadowsports, My system specs are:

OS: Windows 10 v2004 64bit
CPU: Intenl i7 3.4GHz
GPU: Nividia GeForce RTX 2060
Memory: 32GB

DPP: 4.13.10

wq9nsc
Authority

I vaguely recall someone had an issue with DPP freezing that he traced to network drives that were set up even though they weren't being used by DPP.

 

The most recent version is 4.13.1 so if you don't have the .1 version upgrade to that because it may have had some bug fixes.  I have been using that version since it came out with no freezing, the only issue I have found is one common to most versions of DPP where it develops a memory leak that grows with time that will begin to slow it down. 

 

It doesn't matter how much memory you have installed, DPP still will grow sluggish at times after it consumes and doesn't return memory.  I generally use my HP Z840 workstation for DPP and it has twin 6 core 3.4 Ghz Intel Xeon processors with 128 GB of memory per processor and once DPP starts grabbing 3 to 4 gigs of memory it gets noticeably slower even though the workstation still has over 90% of its memory unused under these circumstances with CPU loading staying under 25% peak.  This system has dual Nvidia Quadro cards with 8 gigs of video memory per card so they aren't stealing system ram either.  Once you solve the freezing issue, you will probably find it useful to exit and restart DPP every 90-120 minutes when doing long editing sessions and that will keep it running quickly.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video

Hi Wq9nsc - your system is goals.

Sadly, I don't have the luxury of being in the application for 90-120 minutes as it starts to freeze within minutes of opening it.

It has been awhile since I have used the application so I am refreshing myself with it and I can't get through 12 minute video about the software without the application not responding. And that is with me doing noting but looking at the interface and clicking the buttons. In the middle of one activity, batch renaming a few files it froze for several minutes unfroze and repeated that for 20 minutes. I finally clicked End Task in the Task Manager, interestingly enough the application closed but it still kept open the dialog boxes so I could save the files I was renaming.

So right now I am working on test files to learn the system, but I want to start working on actual photos quickly and this crashing is driving me crazy.

I did three things in December - got a new video card, upgraded to Win 10 v2004 and updated DPP from vs 4.12.2 to 4.13.1.

So last night I uninstalled 4.13.1 and reinstalled 4.12.2 and it is still freezing. So I uninstalled 4.12.2 and reinstalled 4.13.1 and yes still freezing (rebooting between installs and uninstalls).

Screenshot of the DPP 4.13.1 freezing while I was batch renaming a few images - testing the feature.

DPP 4-13 Stops responding.png

Freezing again after uninstall reinstall

Still freezes after uninstall.png

 

I am not in the application long, just a few minutes before it starts to freeze.

 

I  changed the 3D settings Power management mode on my video card from Optimal Power to Prefer maximum performance, but that did not resolve the issue.

I did a couple of quick tests with my system.  I tried the simple batch rename process and had it rename files into a new directory on a different drive, 100 files were renamed/copied instantly.  I then did a batch process converting 40 RAW files to jpg in a new directory and these were 1DX III files which are processor intensive and take much more time than files from my 1DX and 1DX II bodies.  Batch procesing time was 11-14 seconds per file and CPU utilization would peak briefly at 40-55% for each file but averaged under 20%.  Disk utilization stayed at under 1% but this computer has multiple disk controllers and with 6 solid state and two mechanical disks so disk access never shows a high percentage.  A quick test with 1DX II RAW files provided batch conversion between 2 to 5 seconds per file.

 

I did one quick test and let the HP Z840 do a batch RAW conversion to a drive on my HP Z820 workstation over the wifi network.  Speed was still fast but I saw DPP briefly flash not responding when I first selected the networked drive from the other workstation, it probably was just waking up the controller on the other machine but maybe DPP doesn't like networked drives if you have a home network set up with multiple machines or a file server as part of your network.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video

The application isn't stable. I upgraded Windows 10 to v20H2 and I even rolled back DPP to v4.11 and the application is stll Not Responding. I did a websearch and another user was having a problem with DPP starting in the summer 2020.

DPP_Not_Responding.png

I think that Windows must have done something when they upgraded the OS that is now making DPP unstable. I presume it may have something to do with Explorer since some applications now take longer to open or save a file and there are times when I delete an item it takes time to refresh.

 

I've reported the problem to Microsoft, the other user did as well, but with Microsoft they may or may not resolve the issue. I'll call Canon on Monday to see if there is a work around. I really prefer to process my RAW files in DPP as opposed to LR, since DPP keeps the Picture Style and the images tend to be sharper.

 

I hope this is fixed soon as it is handicapping me.

 

Perhaps Canon should make the app 64 bits

One of the many problems with Windows 10 is it seems far more susceptible to minor incompatibilities between itself and various system devices and software.  I spent several days troubleshooting a Win 10 update on my HP Z820 system last year because it would fail when trying to finalize the update.  It was a driver issue from Windows trying to install an incorrect driver for the built in RAID array during that particular feature update but in typical Windows 10 fashion the error message was generic and most probably was a driver but gave no clue as to what was at fault.  After following the useless Microsoft help support to reinstall via a USB drive, I went through the dump logs and found the issue but it isn't something a customer should have to do for a supposedly stable operating system.

 

Good luck on resolving the issue with your system.  I am running Win 10 64 pro version update 2004 with the latest update showing a build of 19041.746   Running with this Win 10 version, DPP 4.13.1 seems very stable working with files from all of my camera bodies.  The only oddity I found is today I needed to grab some files I created years ago with my 1D Mark II body and they appear as monochrome in the cropping window but otherwise work fine.

 

I believe that DPP has been 64 bit for some time, it shows as 64 bits in my task manager and Microsoft Outlook is one of the few processes I see still running in 32 bit.  I do wish that DPP and Adobe would support Linux, I have Red Hat Linux from the factory on both of my HP workstations and I much prefer the security, stability, and speed of that OS to the current Microsoft mess.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video

Photog
Apprentice

I had excellent results by running DPP.exe in Windows XP SP3 compatibility mode. When I run it I am prompted with the Windows User Access Control (UAC), but after clicking yes it works the way I've been used to in the past. Snappy and no freezing! I typically cull 300+ images at a time, so the freezing was driving me crazy!

Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM