Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera Connect - “No card in camera”



I know this app is super glitchy and have rebooted, re-installed several times now and am still getting the same error message.  I tried on both my ipad and my iPhone, every time I connect and try to access my photos I get the error “No Card in Camera”…when there clearly is a card in the camera.  Any advice would be appreciated! 



Lets start with the basics,

Camera Model is?

Brand and type of card you are using?

iPhone and iPAD model(s) are?

Running which version(s) of iOS?

Does Camera Connect make a successful connection with the camera?  Meaning can you control it but not download images, or its not connecting at all?

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It


Had the same issue with my M50 mkII. Tried all the basics - reset wireless settings, redownload the app, format SD card, different SD cards...

The fix? Take the battery out and put it back in. 

Frustrating to waste half an hour messing around with it and going through the hassle of reconnecting and resetting everything, but thankfully it's working now. Really wish Canon would invest just a tiny bit more money into their app.