cancel
Showing results for 
Search instead for 
Did you mean: 

Bugs in DPP 4.8.30.00

psgguy
Contributor

I have been using DPP 4 for a while. I've discovered a number of apparent defects. The nature of them are in many cases so annoying that I am surprised that, as far as I can see, no one has reported them.  Is it possible I am the only one experiencing them? I doubt it. I am running DPP 4.8.30.00 on a Windows 10 laptop that is up to date. These are a few of what I found so far.

* Dpp4Main does not reliably shut down and release or free up all of its memory. After shutting down may leave a large chunk of memory in storage. I have seen this numerous times. It seems to shut down fine when simply starting and ending DPP 4 without doing much. The problem occurs when a lot of work is done. My experience is with checking images and reorganizing them into new folders. I often create and rename the folders using File Explorer while DPP 4 is running. It seems that just dragging photos from one folder to another is enough to cause the error.

* The filter-sort pane in the thumbnail screen is problematic.
 - Turning it on and off by clicking on the Filter tab is inconsistent, it does not reliably open and shut the pane, often leaving artifacts on the screen.
  + Turning the filter ON may add the filter list to the filter pain but sometime it leaves the filter pain blank. When blank the list may be restored by switching the filters OFF then ON. (Is the panel tab supposed to toggle the filter pain or is it buggy too?)
  + When turning the filter on or off the photo thumbnails are not properly refreshed. One must click on one of the thumbnails in order to clean up and refresh the display. This behavior seems to depend on the size of the thumbnails.

* When changing the size of the Thumbnails, the display does not refresh properly leaving a mess on the screen. Clicking on one of the thumbnails after changing the size corrects the problem.

* The folder list does not update accurately and there is no way to refresh it.
 - When a new subfolder is added under an existing folder the new folder is added to the bottom of the open folder list not in its proper alpha/numeric place. Note that closing and opening DPP 4 will display the correct sequence.

* The "Collection" list does not update when some of the photos in the collection are deleted from the computer. This leaves an empty thumbnail with a question mark in the list. This is particularly annoying when the collection is large and many photos are deleted.

* Dragging photos to another folder in the thumbnail screen covers and nearly hides the folder names in the folder list.

I am surprised that Canon would release the product in such a state. If their cameras worked like this Canon would soon be out of business.

9 REPLIES 9

wq9nsc
Authority

I have noticed a few issues with 4.8.3 but not to the extent you have seen.

 

It appears to have something of a "memory leak" with it grabbing without releasing ever increasing amounts of memory while in use but I have never had a problem with it not releasing memory when shut down and like you I do stuff with file explorer while it is running.  I am using currently updated Win 10 Pro on a dual processor HP workstation with 128 GB of memory so the bad memory habits aren't really an issue but it may be another symptom of the problem you are seeing.

 

I don't fool with the filter sort pane so I don't know what problems it may be causing.  What you are describing does sound very glitchy and hopefully that is addressed in the next update.

 

The folder list works fine for me when adding a folder but I have to hit the F5 key (or choose update from the menu).  It doesn't work as smoothly in this manner as most Win 10 programs that will dynamically update without user intervention.

 

I change thumbnail size often while reviewing large groups of new photos and I haven't run into an issue with the screen corruption issue.  This is probably a result of the program not playing nicely with some video cards and drivers.

 

When I drag photos into a directory the view of the photo being dragged is highly transparent making the file structure easy to see.  What you see (or don't see in this case) is related to your video card/color setup.  

 

4.8.3 is working better for me than some of the earlier versions.  The most annoying glitch to me, and it is a minor one, is it wants to start editing with the last photo in the file regardless of which one I initially choose. This only occurs the first time after I create a new directory of photos so it is a minor annoyance.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video

Thank you for responding Roger.

 

I must have sounded very negative, but I want to say I think that I think DPP has potential of being a fine editor. It is the glitches that frustrate me most.

 

The memory leak doesn't seem to hurt me since I have ample system memory. I brought it up because it indicates to me there is some sloppy code somewhere that needs to be addressed.

 

I didn't know about F5 refreshing the folder list. I do not see anything in the user guide about it. I'll have to try it next time I see the problem.

 

Dragging photos does produce a semi transparent image. The larger ones make the folder list more difficult to discern then the smaller ones.

 

There are other usability issues as well, that I think, when fixed, would make DPP a star performer.

 

- Bill

 

 

 

 

Bill,

 

Good points and I don't recall the earliest versions of DPP being as buggy but it didn't do nearly as much back then either.  Of course some little bugs are just funny and my PC experience goes back to the early days when a floating point co-processor was an optional chip for the Intel processors.  One of the early vendors included a simple test program with the 8087 chip and when it finished it proudly displayed, "Paseed all tests", one can only assume they meant passed but it didn't provide a lot of confidence in the diagnostic software.

 

Memory leaks are still annoying and I moved away from Firefox to Opera a couple of years ago when the memory leak issue with FF became too annoying.

 

The quality of Canon products (and for the most part their software) greatly exceeds the quality of the documentation.  Overall I think the documentation with my 2005 era 1D2 is better than that of my current 1DX2; the quality of the manual hasn't kept up with the explosion of features and capabilities.  I see some parallels in the documentation from Canon and GM; they both overdo the basic "getting started" sections but fall flat when it comes to getting the most out of the many capabilities.  I had downloaded and carefully read all of the documentation for my 2016 Corvette Z06 before I took delivery at the museum but to really figure out the customizable instrument panel and driver modes I spent several hours sitting in the car in the garage while it ran off of its battery maintainer.  I suspect over half of Corvette owners have very little understanding of the performance traction and stability modes, customized displays, etc. that the car provides because the documentation doesn't explain them in an organized and user friendly fashion. 

 

I haven't looked at the manual for the lower end Canon gear but I suspect that a primary reason that many of those owners leave them in program or "auto" mode is because their eyes glaze over when they start trying to understand how to really get everything out of the camera.  I shot film for years and have a good understanding of basic photography which makes working through controls, features, and customization doable but for someone new to more advanced photography I suspect that their new camera gets used a few times in program mode and then sits on a shelf gathering dust.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video

My experience goes back to film as well. I now have a G7X Mk II. It is a great pocketable camera for travel photos. This incident takes me back to one of my unpleasant experiences with a Kodak photo editor. It was buggy as well - although not quite as bad as DPP 4. The help desk had me running in circles questioning my skill and reinstalling the code over and over again. They made me wonder about the quality of my computer and everything else. Then, one fine day, a new version was released and viola all problems gone. It seems the help desk was never informed of known bugs or pending fixes.

Let's hope the next release of DPP 4 is better.

On another note - F5 does not help - The folders remained out of sequence.

Bill

jrhoffman75
Legend

DPP 4.9.20 is out on US site. maybe that resolves some of these issues.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic


@jrhoffman75 wrote:

DPP 4.9.20 is out on US site. maybe that resolves some of these issues.


I'm running 4.8.30.0, and in the product, when I go to Help/Check for Updates, it tells me no updates are available. I'll check it directly. 

John,

 

I ran across it when I was checking to check the latest firmware version for the used 1DX I bought for my daughter.  At first glance I didn't notice any obvious changes BUT the first image I converted to a JPG file took significantly longer (maybe 35 seconds) but after that it is down to the 5 to 6 second speed I was used to with 4.8.3 so this must have been a one time initial conversion behavior.  So don't be concerned if the first JPG conversion you run seems much slower, it will be back to normal after that. (Test times were converting full size RAW files from a 1DX2 to a full quality JPG file).

 

One of the Canon sites showed the major changes were adding capabilities for additional cameras and lenses but there may be some subtle performance tweaks. Applying significant noise reduction changes is about the same as 4.8.3 (around 8-10 seconds) so I don't see any big performance tweaks but it may vary on other hardware.

 

In any case I have been using it to go through something over 500 new images since I installed it this morning and other than the one initial slow JPG conversion it has performed without any glitches.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video

Well it looks like I jumped the gun a bit on my original post. This morning (10/4) DPP still says no updates. I'll hold my comments until I've had a chance to check out v 9. And if I find something I will begin a new topic.

 

Fingers crossed,

Bill

ebiggs1
Legend

Same old, same old.  It hasn't been nor is it now ready for prime time.  I wish it was.  Smiley Sad

EB
EOS 1DX and 1D Mk IV and several lenses!
Announcements
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM