Showing results for 
Show  only  | Search instead for 
Did you mean: 

AD HOC connection EOS 6D to MacBook Pro


Though successfully made an AD HOC connection to my smartphone I've had no such luck connecting to my Mac.  If it's possible on ios 7 it's gotta be possible on OS X Mavericks...


I get all the way to the "select camera" option from the WFT pairing icon at the top of my screen, which indicates that it sees my eos 6D.  I select it, click connect, at which point it prompts me to complete the process on my camera's LCD.. and then something happens, the camera disapears from the WFT Pairing Software window.  Once or twice I've gotten my camera to see "Nate's MacBook" too but still the EOS Utility doesn't recognize any connection.


Has anybody had any success connecting the 6D to a Mac wirelessly using an Ad hoc connection?  It must be possible.. it should be trivial. But I've (unfruitfully) poured hours into this.  Very frustrating.


Thanks in advance.



Hi nateargetsinger!


Thanks for posting and welcome to the Canon Forum.


I need to gather some additional information from you.  This will help the community and myself to figure out what could be causing the issue.


  1.  What version of EOS Utility are you running on your Macbook?

  2.  When the camera no longer appears in the WFT Pairing window, does anything happen on the LCD of the camera as well?


If this is a time sensitive-matter, additional support options are available at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

1)  version 2.13.25

2)  nope, nothing happens on the LCD screen to accompany the disappearence


Thanks so much for your prompt reply

Mavericks, 10.9.1

EOS Utility

6D Firmware 1.1.3

Same problem. Very embarrasing during a pay shoot.  Had to switch to different camera and go wired. 

Cost me a customer.

I'm seeing the exact same thing while using infrastructure mode with my home LAN. Been seeing it ever since I got my 6D in October. I can connect to my iPad, my iPhone, my Selphy printer, but NEVER to EOS Utility on my MacBook Pro. And this is the 2nd MacBook Pro I have tried, clean install, and still the same thing. Camera says its all connected, WFT Pairing detects, asks to Connect, then... hang... failure. EOS Utility never sees the connection.


I really need this to work to use wireless tethering, preferably in Lightroom, but if I can get EOS Utility to work, I figure its not too big of a jump to get it working with LR. I would be using an iPhone personal hotspot wifi connection in the field but if I can't get it working at home, what chance do I have on location?


I've watched the Canon USA 6D site for software updates for EOS Utility and I'm up to date. I just pulled it earlier today and that's the first and only version installed on this particular MacBook Pro.


Correction: I had to install EOS Util from the CD (bit of a trick with the new MBP having no drive) but I immediately pulled the latest upgrade from Canon USA.


PS: I have seen the wifi work in as much as Lightroom will see the camera as an import source. But that's only pics on the card, not live tethering. The latter is what I am after with this 6D. 

I just updated EOS Utility as well today.  Had a shoot today, no wireless functionality, disabled wireless and at least got tethering working over USB, tripped on the cable twice.  CANON, Please help!  This is WHY I got the 6D, but it's not working!




I understand how frustrating this is for you.  Getting this resolved in a timely manner is very important.  Troubleshooting and resolving this issue can be very complex and involved. 


So that we can resolve this quickly, I recommend calling and speaking with one of our representatives by phone.  Please call 1-800-OK-CANON.  Support is available Monday-Friday, 8:00 AM to Midnight EST.  You may also call on Saturdays between 10:00 AM and 8:00 PM EST.


We look forward to hearing from you.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


I should ask a clarifying question... where is your Mac when you are attempting to connect to it?  That is to ask... are you at a home, office, or studio where the Mac has a connection to the Internet available?


This is a critically important detail.


In WiFi networking, there's something known as "infrastructure" mode vs. "ad-hoc" mode (which Canon refers to has "camera access point" mode).  


"infrastructure" means that there is a pre-existing wifi network.  E.g. if you are at your home/office/studio and you have WiFi internet (e.g. you own a WiFi router) than that pre-existing interent is referred to as "infrastructure".  In this mode, the camera joins your existing WiFi network RATHER than creating a WiFi network of it's own.  Presumably your computer would already be on the this network.  As long as two devices are on the same WiFi network, they can generally communicate with each other.  There are some exceptions... some network routers (this is common at hotels and even some coffee shops) add a layer of security by blocking devices from being able to communicate directly.  This is so that presumably one guest cannot start browsing the shared network services your laptop might be exposing.  Commonly users who own multiple computers might allow them to see each other's filesystems when you are at your home or office... but you wouldn't want others browsing these files when they are strangers in the same hotel.  The bottom line is in most home or office environments this will work, but there are some exceptions (hotels are the most common to implement this extra layer of security that isolates each device.)


Ad-Hoc is different... this mode is intended for when you are proverbially "in the middle of the desert".  When there is no common WiFi internet presence that both devices can join, one device can create it's own network and the other device can join it.  This allows those two devices to communicate with each other -- even though neither device can access the Internet.


If your Mac is on your home/office/studio WiFi network (aka "infrastructure" mode even though the Mac doesn't refer to it as "infrastructure" mode per se) and the camera is still on Ad-Hoc (aka "camera access point") mode, then those two devices will NEVER be able to communicate.  You would need to switch the camera over to "infrastructure" mode.


If you really are using "ad-hoc" mode on the camera and want to use it that way, then your Mac has to leave any WiFi network it may already be using (which means it loses internet access) and you'll need to use the Airport settings on your Mac to join the camera's WiFi network.  If you are in a studio home/office/studio that has WiFi internet available, this is probabaly not what you want.


Tim Campbell
5D III, 5D IV, 60Da

Speaking for my own experience, I do understand the difference between ad hoc and infrastructure. As I mentioned in my previous post, I have 6D WiFi working with my iPhone, iPad and Selphy printer. All of these are "ad hoc" and I've named the settings with "-CAP" to indicate Camera Access Point. I turn on the 6D WiFi, then I have to change or choose the other device settings to Join my 6D WiFi name.


For using the EOS Utility, I'm trying to use infrastructure. In this case I have the camera search for my home WiFi network, which it finds. Apparently the only option I have to connect to my AP is thru WPA2 so I enter the ascii password. This works. I then go thru the steps to initiate pairing, start the EOS Utility if its not already running. WFT Pairing appears in the menu bar, sends a notification that an EOS camera is connected, and shows the Select Camera dialog. I select it and Connect. At this point one of two things happens:


1) I get a popup from either EOS Utility or WFT Pairing telling me to complete the steps on the back of my camera. However, there are no steps there to complete. I can only Exit the connection, or Confirm the settings, which is display only. There is no way to exit this popup manually on the Mac.


2) A popup (might be the same as above) appears briefly, disappears, the EOS Utility main menu comes up, but everything but the last option (Monitor Folder, which is merely a preference setting) is greyed out.


In both cases the camera's Confirm Settings looks correct, except that sometimes the auto assign of an IP is all zeroes, sometimes it's a good IP address from my router. This doesn't seem to have any bearing on whether WFT Pairing will see the camera, however briefly.


Now here's the interesting thing. Yesterday I tried setting it up using my iPhone as a personal hotspot. Using that as my WiFi infrastructure access point, switching my computer over to it and creating new 6D settings for it, I was able to get it to work. That's good to have/know, but I would like to use this around the house when I am using my home studio without having to switch over to my cell phone.


I'm using an Apple Time Capsule as my router. Because of how Verizon hooked me up to their system, it's in its passthru mode. I don't know if that matters, but at any rate, I could not get it to work with the Verizon router directly either.


I also see that OS X Image Capture app (OS X default app for pulling pics off cameras and cards) does see the 6D when I make this WiFi connection.


I see this in the console log whenever this fails:


3/21/14 3:48:36.109 PM Image Capture Extension[544] [2] Failed to register for death of process with pid: 555


where the pid refers to the PTPCamera process. No useful messages from it, though.


Right now my guesses are that there is some sort of miscommunication between the camera and the Pairing utility, or something like Image Capture is interfering. Although the latter guess loses credence considering I got it to work with a personal hotspot.


I am using the latest Canon software available here, on OS X Mavericks. Camera firmware was just updated to 1.1.4 yesterday.


My experience is the same (except that I haven't tried the cell phone hotspot, glad to know that would work when on location), and I am curious if Canon has tested with Apple Airport Extreme.  Are there IPV6 settings we should know about?  I haven't had any time to test that part of it.  Yes, I HAVE tried switching between many different channels to see if there was a collision with any neighboring WIFI setups.


Enter for a chance to win