cancel
Showing results for 
Search instead for 
Did you mean: 

750D utility

jrulier
New Contributor

Any news about the possibilty of using EOS Utility with an EOS 750D?

4 REPLIES 4

Are you asking if EOS Utility 3 will work with your 750D?

 

Capture.JPG

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic


@jrhoffman75 wrote:

Are you asking if EOS Utility 3 will work with your 750D?

 

Capture.JPG


And the answer is that it should if you also have EOSU 2 installed. EOSU 3 is incompatible with most (all?) Rebels, but it knows that and automatically calls EOSU 2 if necessary. At least that's how it used to work; I haven't tried it with the latest release of EOSU 3.

 

Also, recent EOSU 3 installation files will install EOSU 2 at the same time unless you tell it not to.

Bob
Philadelphia, Pennsylvania USA

Thanks for this answer. Yes, I have installed the whole latest exe but still no chance to make it work.

 

It reads: "When any model other than...EOS 750D...is connected, EOS Utility 2.14 will be started." meaning EOS 750D runs Utility 3, no?

 

I am so confused!

Your assessment is correct. Call Canon on their phone support line or email them.
John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic