cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

R5 body with WFT-R10A connection problem with T-Mobile 5G Hotspot

CP_LA
Apprentice

Just bought a R5 with the WFT-R10A. I bought the WFT for the dedicated battery for transmitting.  I need to upload to an ftp site using a 5G Samsung through T-Mobile.

I have updated the firmware on the WFT to 1.2.1 and to 1.7  on the camera body.

I can upload through my home wifi and an older phone using 4G to the FTP setting. But when I connect using the 5G phone, I get an Error 41.

The FTP settings are ftp.photoshelter.com, login, password, Port 21, Passive (Enabled}, IPv4-Auto setting; IPv6 – Enabled. These are the setting I use. Works with home wifi and 4G, but not 5G mobile.

I have tried enable/disable “passive” with enable/disable “IPv6” combinations, but to no avail, and get Error 41.

Has anyone else had this problem?

4 REPLIES 4

John_Q
Product Expert
Product Expert

Hello CP_LA,

Based on my research into this issue, an Error 41 may occur if the encryption method is set to Open system. Are the camera and the access point set to use the same encryption key(password) for authentication? Make sure the correct encryption key is set on the camera and the access point(phone). You do want to set Passive mode to Enable, so that's good. 

John_Q. As previously stated I have no problem setting up transfer through FTP using my home wifi and an older 4G phone using the connection wizard, with no problem. Doing more research into this might be a T-Mobile issue. T-Mo is ip6V dedicated network, with ip4V causing problems.
When setting up with T-Mo 5G Samsung S20, I put 'ip4V' to auto and enable 'ip6V'. Does the 'ip4V' remain enabled with the 'ip6V'? Is there a way totally disable 'ip4V'? I ask this is I use a program Photomechanic to upload to FTP, which has an 'ip6V' option that allows use with 5G.

John_Q. I reached out to Photoshelter to see if there might be an issue on their end. Currently, they are still on ip4V and do not know when they are going to update to ip6V.  This is supposedly a known problem at Photoshelter and T-Mobile. The T-Mobile dedicated ip6V causes conflict when going direct from the WTF-R10A, via the FTP option, possibly causing the error 41.

In my previous reply, I can upload to Photoshelter through Photomechanic with an ip6V upload option.

When setting up with wizard, there is no option to set up the encryption method. Just choosing my network and setting up password. It has no problem seeing the phone hotspot.

CP_LA and John_Q

Very helpful.  Kudos to both for digging.  I had found the same info John_Q did.

Canon : Product Manual : WFT-R10 : Responding to Error Messages (start.canon)

Will continue to follow this topic.

~Rick
Bay Area - CA


~R5 C (1.0.5.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It
Avatar
Enter for a chance to win
Announcements